Black object from SketchUp Datasmith

After import Sketchup with datasmith, there is few object error, black object. Changing material not working, still black. This bug shows up after updating UE to 5.2. i know there is solution in skp, explode then group again. But there is much object and the UV gets wrong.

Before it i was use UE 5.1, there is no problem time to time. The skp version still same. And also in skp, the face direction is not flipped, but in UE flipped itself. I hope Epic Games solve this bug.

Software:
SketchUp 2022, 2023
UE 5.2, 5.2.1

My 3D file:


1 Like

change texture got no effect maybe there got sth. trouble on normal.

you can try to move your vision into these object and find out if there got some color inside those objects

deleting material (no material) still black

no color inside object because its backface (transparent)

are they are box or just plate
if they are box, move the vision into these mesh and turn vesion back maybe can see sth.
Or change the material into translucent shader and find that if can see sth.
If they are plate, onlything you can do maybe move it into blender or what and reversal it maybe can solve the problem, i cannot visit google so i cannot download the mesh.

i found solution, in modelling mode, click normals.
but if there many object, this will take time and also reimport will reset to default again.

i prefer workflow sketchup → blender → UE untill this bug solved

2 Likes

I am also facing this issue. I managed to work out that exploding the groups and regrouping them works, but it is also affecting lots of my FlexTools objects, which I need to remain as dynamic components. I have found Profile Builder 3 objects are particularly badly affected, but only when drawn in the green y axis!

Recently native sketchup objects have also been turning black on import. I have discovered that any object copied and then flipped seems to have an issue. Also objects using the flip tools in the FlexTool toolset have this problem.

@ubt.360 mentions using modelling mode to flip the normals and as stated, these do reset on reimport. An alternative fix is going into each static mesh’s settings and applying recompute normals. However, this is a longer process and also resets on reimport for some reason… Why this isn’t saved as an object override I am unsure.

I am now exploring the option of importing into Twinmotion, then exporting as datasmith from there into UE5.2… Let’s see what happens.

Has anyone had time to try 5.3 preview with the new datasmith plugin for that version?

2 Likes

I had this issue in Twinmotion, when using import trough Datasmith. I found that if I explode the mesh and regroup it, fixes the problem for me.

The same problem occurs in sketchup 2023 and datasmith 5.3 plugin. I did the explode en regroup in Sketchup but this should be solved through TM. Has anyone with this problem put a official bug tot twinmotion support?