Download

Black lighting but lightmass computes ok!

Hi folks,

So now i’m getting this strange behaviour after building my lights.
I already read some threads but I didn’t find a solution to my problem.

Every mesh has a hand mapped primary UV channel and a secondary UV channel that can be inspected in the static mesh editor. No overlaps whatsoever.
Every light is set to static. I don’t need any transitions or changes at runtime.
Materials are fairly standard, but are tiling a lot on a custom UV channel on the mat slot.
Lightmap resolution is set to a whopping 2048 (just for the hell of it really, i do need to optimize it a lot).
I have an Importance volume encompassing the whole scene.
The glass is set to a translucent material.
Glass and ceiling are flat polys so i’ve checked two sides lighting and cast shadow as two sides in the lightmass properties.

Funny thing, Lightmass computes the lightmaps very well, as you can see from this screenshot:
a3c20f347069efbbbe7039fe4f70fc79cfd57db1.jpeg

The textures are there as you can see from the unlit view:
6d84a1422a16e9bbc6aea190db0f2659de276020.jpeg

But the darned lit viewport still renders black:
b350b833a3dc849c124dd282e421a2f5d25542a9.jpeg

Anyone got a clue on why is this happening?
I’ll keep testing.

I had this happen yesterday. After changing the lights intensity it came right. Not ideal but it worked.

Seems like I fixed the issue somehow by making new materials by scratch.
I was using some pretty extreme settings to work with the maps and then clamping, using some less extreme settings made my light appear again.
Dunno why though!

Hi Max,

I’m sure you’ve done this already, but have you built lighting?

If you remove the the glass windows, and rebuild lighting is everything coming through correctly at that point?

If so, I would look at one of two things.
1)It possibly something with the mesh. Is the mesh a single plane with a two-sided texture or does is it a narrow box?

  1. There could be something setup in the material that is blocking light. Can you post an image of your material setup?

To rule out the mesh as the culprit can you make a new material with it set to translucent, a vector3 constant for color, and an opacity with a vector constant of .5.

Let me know and we’ll dig into this a little more! :slight_smile:

Tim

Thanks Tim!

In the end it was just some crazy materials settings (roughness mult by 80 and other crazy stuff)

Redone materials from scratch, i’m now building a single master material to instantiate everywhere.

Scene now looks like this:

Nice!

Just a question though: is there a volumetric light shafts already built in or do I have to make a geo and assign a translucent map to it like in the old days?
Thanks

Max