Black Gradient on the mesh in UE4

So, i created the mesh and textured it in Substance Painter, brought it over to UE4 and…there are weird black Gradients on the mesh, but they don’t derive from the Material but from the Mesh normals directly. I deleted all the vertex maps in Modo, created Mikki’s export…still same issue. Used Vertex Normal tool hardened selected edges at 179, recreated Mikki…still black Gradient. In Substance everything is fine.
It’s a pillar. I created one fourth of it and copied it around. Is it an issue with my mesh and it’s normals? is it a lightning issue?

Open your Static Mesh in the Editor and disable this option. Press Save and close the Editor and apply. Or Triangulate your model in a 3D application.

Ahh uncheck recompute tangent and that did the trick. Thanks so much (since i already had the mesh tzriangulated in modo).

I don’t even know why that isn’t disabled by default. It doesn’t do anything but ruin your model.