Black Circle Glitch on Sprite when Camera Pans? (Possibly related to MotionController component)

I’m seeing a strange graphical artifact on my sprite sometimes when I pan the camera around and I can’t figure out what might be causing it.

I currently have a Blueprints object representing a world map, which contains a sprite with an orthographic camera attached.
I have WASD set up to pan the camera around using SetRelativeLocation on the camera.

Everything seems to work fine, except that sometimes while panning around (not always in the same place or with any noticeable regularity) I encounter an effect where a black circle shows up and if I continue to pan it will gradually move in some direction and soon fade away. If I move the camera back in the exact same position, it’ll show up in the same way again. It may possibly be different every run or something though because it seems to happen in different places and it’s not always equally easy to make it happen, nor does there seem to be one specific camera position that will always cause it. The effect appears as though a black sphere was moving around, overlapping through the map sprite and then slipping back away from the camera.

I’ve attached an image showing what I mean, compositing 2 screenshots taken seconds apart. The top shows the black circle, then after panning the camera horizontally, the circle has moved across and shrunk, as though it was really the end of a sphere perhaps.

Why might this be happening? Is it some sort of lighting issue? At first I thought it might have been that I had a MotionComponent in my world map object and that the sphere shape was somehow being drawn or interfering with lighting in some way, but when I got rid of that the camera still worked the same way and the problem still arises… after that, I’m out of ideas regarding anything circular that might be causing it.

The only things I have placed in the level are the world map object, and a post process volume that doesn’t fix the issue when it’s disabled anyway.

Is this the shadow of your own pawn? Try to disable the shadow of the light. Sorry I’m just guessing.

Looks like it.

Interesting… sounds reasonably likely.

I’ve made my own pawn class (with no mesh or anything), but I see when I run the game I get among other things a DefaultPawn appearing in the World Outliner (even though I thought I set it to use my new pawn class, but maybe I didn’t set the game mode properly or some such…). Default Pawn does appear to have some mesh components, which I assume could account for this.

Gonna give it a look and see if I can fix it…

Changing Default GameMode (which I should have changed already, but it must have slipped my mind and here we are) to my already created GameMode changes the DefaultPawn to my custom pawn. Hopefully that will have fixed it, but I’ll have to mess around for a few minutes and see if it crops up again…

Ok, scrolled around for a while in various directions, didn’t see anything yet. Will post again if it comes back but it makes sense it would be fixed now by looks of things.

Thanks for that, guys.