Download

Black Artefacts on built lightmap: how to get rid of them?

Hi guys…

Just started to play around with UE4 again after a 1.5 year break and going back to Unity. Currently I want to give the new volumetric lighting feature that, apparently, can be used with lightmaps, a try. Mostly because this combination is currently unachievable with Unity, and a pretty sexy feature if it works well.

That is why I imported some of the 3d models I was using in Unity with fully dynamic lighting (baking lightmaps with the new lightmap baking tool in Unity 5 is no joy anyway), and tried to see how to set up indoor lighting in Unreal with baked lights.

I ran into trouble with one of my models though: The model was built to minimize texture stretching. So some small UV Islands have been created as I had chipped away parts on the model where a continuos UV would have resulted in quite heavy stretching. When I bake the lightmaps for those models, these parts are completly black.
Pics:

https://forums.unrealengine.com/filedata/fetch?filedataid=118058&type=thumb

This is the mesh in the Editor with baked Lightmaps. You can clearly see the parts of the UV which are problematic

https://forums.unrealengine.com/filedata/fetch?filedataid=118059&type=thumb

Same mesh without lightmap being baked for it (set to movable)… obviously the problem comes from the lightmap

https://forums.unrealengine.com/filedata/fetch?filedataid=118060&type=thumb

Here you see the UV map… many small islands to minimize stretching.

What is the best course of action to use this model, without changing the UV for the texture (and thus introduce texture stretching), while getting rid of the artefacts when setting the model to static? Do I have to build a seperate UV Map just for the lightmap? Is it possible to assign this to the lightmap building somewhere in the editor? Is there any other way to reduce the issue without completly redoing UVs?

I already tried uping the lightmap resolution. Only result was razor sharp shadows and a build time that is already ungodly with a <10 meshes in the scene, only 3 stationary lights and 12 virtual cores churning on it… yeah, I need to turn the resolution back down :).

Thanks in advance for any help