Bizarre dynamic lighting problem

It makes no sense that objects set to receive dynamic shadows do so, but some that are set to NOT receive them still do:

Are you sure that it is not static shadow? It is hard to understand the issue from the description you provided. Consider explaining it in detail.

Hi Swiss_Cheese,

The option you’re pointing to for “Dynamic Shadowing” only controls whether the actor should cast a dynamic shadow. There is no setting in UE4 that can disable shadowing completely for an actor. You can disable it from casting a shadow, but not receiving one. If you need that to be the case it would have to be a movable actor and be assigned a lighting channel, BUT it will still have self shadowing because that cannot be disabled.