Download

Better way to deal with eye adaption?

I have a little cave of sorts. I want there to be holes to the outside (some at the top, and for the exit). The problem is that even at a distance of about 50 meters, looking to the outside makes every bit of the surroundings completely invisible. This is absolutely terrible for gameplay. Can’t see obstacles or enemies that might be there. The only solution I’ve come up with is to limit the auto exposure to a good value for the inside of the cave. Problem is, as soon as you step outside the brightness never adjusts so everything appears blinding. Is there any good solution to this problem?

You can see the problem demonstrated below. First pic is lit, second one is lighting only to give you a good idea of the distance.
uelightexp1.png
uelightexp2.png

You could use another post process volume for the cave and set auto exposure to a suitable value.

Hi, this seems like a pretty nice solution; However when going from Global Post Process to one of the post process volumes, the change in light is instantaneous (However transitioning from a post process volume to global post process seems to be fine). I’ve tried setting the min brightness to 0 in the post process volume to no effect. Max brightness set to 0.03.

Hi Minderaser,

The transitions are based on distance, not time. See under “post process volume” settings called "priority " and “Blend radius”. You need to make sure the priority is higher than your global PP and that radius is large enough to see the blend you want.

Try setting both min and max to 1, then go to a bright spot and lower min until it looks OK, then go to a dark spot and raise max until it looks good. Or maybe I said those backwards, never can be sure until you try with this stuff :slight_smile:

Thank you! Blend radius seems to have been the main culprit here (probably along with priorities). Works great now.