Download

Best way to import multi UV channel?

Ok, I have a model of “well”, something like this:

fc5dc9d55703605c25caf7d33723324d067f2476.jpeg

It is made of 4 object, attached together on object.

Every object have its own texture, unwrapped in uv channel “2”.

So, if I import model like that in UE - I will have problem with “overlapping uv’s”.

What is best way to import model like that?

1.) Create a complete diffuse map with uv channel of “well” model, and import in engine?

2.) Use multi-sub object to every object of my model, and then export it?

Move the second channel’s UV’s(the ones you prepared for textures) to the first channel, and then prepare a new UV layout for lightmaps with no overlapping UV’s in the second UV channel. UE4 can also generate lightmap UV’s so you may want to try it out as well.

Hi Tomislav,

I’m not sure why you would really need UV channel 2 with this method.

If each mesh has its own texture you can setup each of the the four meshes to be in UV1 (3Ds Max and other programs, this will be UV 0 in UE4). They can overlap all they like and it will not matter since you’re using Multi-Sub-Object material and these individual meshes are given their own material ID.

So at this point you really only need a single UV for all four meshes for your textures.

Next you’ll want to setup a Lightmap UV for the second UV channel (3Ds Max and other programs, this will be UV 1 in UE4). In this UV it is imperative that none of the faces overlap for all four meshes. This is where you’re lighting information will be baked in UE4.

When you import your mesh into UE4 and open it in the Static Mesh editor, you’ll notice that you have four Material slots, and two UVs. If you enable the UV button in the toolbar so you can see your UV you should see a mess of UVs overlapping for UV0 (UV1 in modeling programs). If you use the drop down you can select UV 1 (UV2 in modeling programs) to view your lightmap layout where there should be no overlapping faces.

In the details panel in the SM editor double check the Settings tab and make sure that Lightmap Coordinate Index is set to 1. This will assign your UV1 to be the lightmap.

I hope this helps.

Tim

Thank you, i will try this weekend what is best way.

But if I make complete diffuse map of my model - i will only have one material.

If I don’t make diffuse, just export model with multi sub materials, i will have 4 materials.

Which is best way?