Behaviour Tree task node, Vector KeyValue in blackboard invalid

Behaviour Tree task node, the function node “Set Blackboard Value as Vector” fail. Vector KeyValue in blackboard invalid

I wanna try use the “Behaviour Tree” to get my enemy action in heself as the UE4 document. But I got some problem.

I have done all things in the document Behavior Tree Quick Start Guide | Unreal Engine Documentation

It is step 5, the task is to find a potrol location to move.

I run the BT finally but the actor didn’t walk to the target location.

As I see, the “PotrolLocation” is invalid as following picture

and the “Set Blackboard Value as Vector” node in the task node worked well.

I took much time to get the way, but I failed. Can someone tell me why and help me to solve this problem. Thank you so much.


I solve this problem by my self as see the toturial again and again.

The task node must assign the “PotrolLocation” variable once by following steps :

  1. check “Instance Editable” in the valiable detail.
  2. go back to the BT, select the task node witch the “Set Blackboard Value as Vector” node.
  3. select a blackboard key to the “PotrolLocation” valiable. thus, the “PotrolLocation” variable key should be set to “PotrolLocation” which in blackboard.

Thank you so much for taking time to answer your own question.
I spent way too much time trying to resolve similar problem after watching some tutorial which made it look like it was dependent on names equality.
It doesn’t matter if ‘name of variable in Blackboard’ and ‘name of blackboard key in task’ are different or equal - you have to bind it manually in task details in Behavior Tree. Otherwise it binds public task variable to first blackboard variable regardless of name or type.


Ah thanks, I got stuck at the same part. I built myself some weird workaround

Need to get ”Owners Blackboard“ to “Set Value as Vector”.

Hi I am following that introduction to Behavior trees and thank you for helping me with that issue.
I now have a problem with the “has line of sight” decorator it is not changing the bool to true.
I have my own Topic open if you know the answer you could maybe answer there.

Thank you and anyone else who tries to help me!

I am just stupid, I forgot to set this bool to true :sweat_smile:
It is inside of the AI controller

I just want to thank you for finding this, I was stumped on this for a long long time!

Thank you so much. :sweat_smile:

Hey, its not working for me , could you help me out with it?