Behavior Tree MoveTo Not failed but location is valid


I seem to have an issue with the MoveTo from the behavior tree.
While it works for all the other part of the behavior tree. One specific doesn’t work. It restart the sequence everytime it hits the move to.

See attached screenshot, but I check for a object, go pick it up (move to works fine), then check for a chest depot, and Move To it, but there the loop is restarted, the 2 breakpoint after don’t trigger at all.

The FindChest and CheckForRC are excactly the same but with only one difference in what object they are looking for.
I also print the location of the chest and it prints fine. But somehow the moveto fails. I overwrite the same blackboard value for the moveTo, so i know this should work.

What is weird is that if in “FindChest” i just modify the vector value with 0,0,0 then all works fine. It s just finding an actor that doesn’t work.

I got only one warning in the log :

LogPropertyNode:Warning: Property BTTask_MoveTo::bObserveBlackboardValue is an editcondition for BTTask_MoveTo::ObservedBlackboardValueTolerance, but is not marked as EditAnywhere.

But I got it for every moveTo node.
I tried using 2 different vector entry inside the blackboard, but it doesn’t change anything.



I found the issue. Just writing this question actually made me understand my error. I needed to use a Reachable point for the chest, as because it has collision while the location was printing, it was not reachable. So a radius around the chest in reachable area worked fine!