Download

Beam Particle system visibility issue

Hi,

Depends of the camera angle my beam particle system dissappear from the scene. Some kind of visibility issue. Here is a video:

Any idea??

thanks so much

It has to do with the garbage collection, and how that affects beam visibility. If you’re using the “visibility” nodes to enable and disable the beam, you’re going to get that bug. Instead, switch them over to the set active nodes, and it should work fine.

Looks like a bounding issue. On the cascade toolbar, click the bounds button so you can see how big the bounding box is. If the bounding box is not in your camera’s field of view, the particle system will disappear. In the particle system’s main details tab, in the bounds section, check the “use fixed relative bounding box” checkbox. If the beam can reach anywhere in the room shown in your video, then make sure the entire room fits in the bounding box.

Nice looking game btw.

Hi xnihil0zer0!!

I was trying some code fixes but finally you were right it was a bounding box issue. I made it bigger and now the effect is visible all the time.

thanks so much!!

Bye!

ps: its only a personal project for learning purposes (and portfolio) :wink:

Should always try to use ‘Set Fixed Bounds’ on a particle system where possible, otherwise the CPU will recalculate the bounds for every particle each frame.