Beam Not Following Linetrace, Stuck Trying To Understand Why? Unreal

Hi, My Niagra Beam Was Working, When i Suddenly Duplicated It To Use For Other Weapons As A Means Of Bullet Trace, But Now The Beam That Worked Is Now Not Working, I Am Very Stuck As To Why, Its Not The Bp, It Might Be The Niagra System, Or It Might Be The Engine Just Stopped Functioning Properly, Idk What To Do, Do I Update The Engine, Do I Try To Make Another Beam FX And Test It, But I Fear The Result Will Be The Same And I Have No Way Out

1 Like

I doubt anyone can give you and tips unless you give detail information about the precise issue.

for the like billionth time.
Writing “sh*t don’t work” when asking for help, doesn’t allow us to help you. :roll_eyes:

Ok I Will Send The Materials Your Way, But Know That I Do Not Hold The Previous Working Video Or Imagery Of The Beam,

Some Video,
3 Characters And All 3 Have The Same Issue, it Started With The One Duplicate For The Revolver Then The Laser Gun Stopped Working And Now Guantlet, I’m Gonna Try Make A New Emitter From Scratch And Hopefully It Works, If It Doesnt I Guess Ill Post Here The Comments

Says 100mb Limit Here, The Vid Is 20mb

I Made A New Niagara Beam From Scratch And I Still Have The Same Issue, Not Sure Why

The System Works, It Must Be Something In BP, It Must Be Error Within The BP, Or Something, Cause It Was Working Well Until Now, But What Could Of Happened Within The UE

@LilosGames Can We Please Drop This Strange Capitalisation Thing. What’s up with that? It’s really hard and annoying to read. Also, the link is private, no one can access it.

We know literally nothing about what you’ve done and what changed between “it was working before” and “it’s no longer working”.

Perhaps you could show us some screenshots of the relevant script? Also, it wouldn’t hurt if you explained what is not working, precisely. How does this issue manifest?

FIxed: Line Trace And Beam Not Working.mp4 - Google Drive
I Simply Asked For Help And Camel Case Is A Popular Method Of Speech Where I Stay

Here Is The Older Project:

As You Can See, It Works Well, Ima Try Adding Back The User. To The Thing And See If It Works By Chance

Hi, I Changed It Back, Yet, No Success, If Anyone Can Help, It Would Be Tremendous

I FIXED IT! Just Turn Off Local Space In The Beam Emitter Niagra System, Cause The Issue Is, The Line Trace Is In World Space While The Beam is In Local, The Translations Between The Two Get Messed Up And Confused, Easy