BC7 compression setting crashes Editor in DX11-only project

What happens:
In texture settings windows, after changing Compression → Compression Settings to “BC7 (DX11, optional A)” the entire Unreal Editor closes without warning. The crash report window doesn’t show up.

How to reproduce:

  • In Project Settings → Project → Supported Platforms leave only Windows

  • In Project Settings → Platforms → Windows leave only DirectX11 (SM5)

  • Open a texture, change Compression → Compression Settings to “BC7 (DX11, optional A)”. The Editor should close after doing this.

It happens on two different computers, Windows 7.

Hi Oskar,

Thank for the repro steps, but unfortunately I’m not able to reproduce this on a Windows 8.1 or Window 7 machine.

I do have a couple of things I’ll need from you to investigate this further though.

  • If the editor is shutting down without the Crash Reporter window coming up this is likely a Crash in Windows that is logged there. Follow the instructions here to get the Windows Event Crash: A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums
  • I’ll need your DXDiag
  • I’ll also need you to verify if the crash happens on another Texture as well that is not one created for your project. You can do this by using the View Options in the Content Browser and then in the Engine Content folder you can locate a texture to change it’s compression settings. If this does not cause a crash, can you upload your texture that you’re having issues with. I’m not sure if this is a content issue, but it may be worth looking at as well.

Thank you!


Having the same issue.
Windows 7.
UE 4.10.
You have to apply steps exactly the same to reproduce it.


I’m still unable to reproduce this from my machine or others that I’ve test on. Would you mind providing the information I had requested above so that I can investigate this further?

Any crash logs, the call stack, along with your Machine ID and Epic ID would be helpful if you’re seeing the crash reporter window.

Thank you!

Hi Tim,

Thanks for your reply.

I was able to reproduce the error today with the same steps and using a Starter Content texture. No crash reporter, just shutdown.

From the log:

[2016.01.09-20.52.29:037][232]LogTexture:Display: Building textures: T_Brick_Clay_Beveled_D (BC7)
[2016.01.09-20.52.29:258][232]LogThreadingWindows:Error: Runnable thread PoolThread 2 crashed.
[2016.01.09-20.52.29:258][232]LogWindows:Error: === Critical error: ===
Fatal error!

The project: http://oskarswierad.com/public/ue4/BC7_UE.zip

DXDiag: http://oskarswierad.com/public/ue4/BC7_UE_DxDiag.txt

Opening the texture file inside UE should close the entire editor.


Thank you, Oskar!

I was able to see the crash happen in your project, and oddly the crash happen by just trying to open or right-click the texture file, but when I set the project back to use all platforms and support DX10, then re-launch the project I can open the file again. Then I can set it back to only Windows and DX11 and it will no longer crash. For some reasons I cannot get it to reproduce on my end unless I just leave it at the settings it was.

I’ve gone ahead and created JIRA UE-25224 for this. Hopefully something useful can be seen by the dev in the log and minidump files that can be useful to prevent this from happening.

Once there is any update to the ticket I’ll update here.

Thank you!


This issue has now been fixed and should be included in the final UE 4.11 release (CL #2920749).

The problem was that ispc_texcomp.dll was missing in UE4 binary release builds. This file is included on github, though, so you can also get it from there.