Download

Batch file for GearVR puts inaccessible application on Galaxy 7

Hey all,

This is my first post on a forum of this nature so forgive me if my post in out of format, or insufficient.
My problem is that I have been trying to package and deploy a simple project from UE4 to Gear VR to make sure i can get one working, and to eventually develop this project into a releasable game on GearVR. However, when I initially created the project, I was getting unsigned APK errors, with the icon of the application appearing in the app tray of my Galaxy 7 after i ran the .bat file UE4 created on my desktop and crashing due to the same unsigned APK error on opening. I went through forums for a while and eventually figured out how to sign my APK, and have since fixed that issue(I believe). This is where the real problem comes into play. Now that my APK is supposedly signed, running the .bat file results in no application icon being created on the phone. I know something was installed, because in my application manager the app will always appear and say it is installed, but as you cannot open an application from the app manager I have been unable to run the project at all for testing. Googling for days turned up no results in a sea of “Ive never owned a phone before where are my apps located” results, I hope someone here may have some idea of what may be causing this or how i can get around it.

Apologies if this post is insufficient for you to help me, and thank you for your time.

Gear VR applications signed for distribution will not show icons; they are launched another way. Just use development (not shipping) and it should be fine as long as you generated your OSIG file and placed in in the project’s Build/Android/assets directory.

Thanks for the reply! I will update this post as soon as I am able to test if that fixed my issue.

You can also use this app: https://play.google.com/store/apps/details?id=com.sika524.android.quickshortcut&hl=en
to create an app icon to launch the game :wink: Oculus always wants you to go over it’s launcher which is why it’s hidden by default.

Thank you, both of these answers worked for getting my icon onto the phone, however, I still have an unsigned APK error. I have followed all the steps to creating my OSIG and I have done the same for signing the APK, but the problem persists.

Make sure the osig file ended up in assets. You can open the APK as a ZIP file and check. If you placed it in your project’s Build/Android/assets directory (you need to create it), then it should be there.

Wow, thank you, this finally worked. It should be noted that the documentation was very confusing on this folder hierarchy, as following its directions had me trying to find a directory in my project’s folder named Build/Android/Java/Assets (which doesn’t exist anymore if it ever did), and did not say that I should create it myself, so I was very confused as to where i could find these folders and ended up with my OSIG in the wrong location.

Thanks again for your help Chris.