Download

Baking + Ray Tracing Reflections

Hi eveyone,

I’m making a big Archviz interior and I would use baking for lighting and Ray Tracing for reflections.
Is there any way to turn on reflection Ray Tracing only? If I activate Ray tracing on the projects preferences, it activate every Ray Tracing functions but I need only reflections!
I have tryed to deactivate all the Ray Tracing Effects by command but then if I reactivate them individually they don’t work… even if I try from Post Priocess Volume I can’t.

Probably I make something wrong! :confused:

Thanks!

Read this:

It contains CVars that are for turning on/off specific ray-tracing functions after having enabled RT for a project.

For shadows
Static light cannot be raytraced. If you think its raytracing, your doing lighting right.
If you want to disable on stationary/dynamic lights, theres an option for it in the light, but, theres no reason to disable.

The rest is in ppv, remember to set it to infinite extent.

With my GTX 1080 Ti the raytracing performance are too low so I thought to bake all the lights and take advantage of the raytracing only to have a better realism for the reflections.
I think that it’s possible?

Thanks

Well, its obviously possible, and is more common than not, you should not encounter issues with it or even have any trouble doing it as its just setting some lights to static and nothing more, if you do your encountering a bug.
Btw: Reflections are the reason raytracing is so expensive, shadows are not. Set reflection max bounces to 1, add 1 reflection capture per room (Box reflection, not sphere. Incredibly common mistake that even pros make.), and add r.RayTracing.Reflections.ReflectionCaptures 1 to your .ini or just use it as console command.

Thanks a lot Bits360!! I will try :wink:
At the moment I have some problem to understand the correct method to illuminate my foliage… Unfortunately I cannot use the Landscape material with my static mesh and I have paint the grass over it, but baking doesn’t properly illuminate the grass :confused:

Foliage is a nightmare to light up decently, i suggest raytracing your directional light and ONLY your directional light.

Thanks Bits360!
Now I have another problem… it’s my first job in Unreal so I have a lot to learn! :slight_smile:
I have baked all the static light but now if I add some Anima animated people how can i illuminate them? Obviously they are not seen by the bake because they are movable…

As in recieve or shadow them?
If you need them to cast shadows, use stationary not static and keep an eye on the 4 stationary light overlap limit, and in the light itself disable raytraced shadows in settings

If you just need them to recieve light, Unreal already has you covered. You may need to turn up volumetric lightmap density in world settings.

Tip: Light cost and bake time is based on source radius, not brightness, lower radius on small, low contribution lights to save fps, but, setting it too low will make it clip out at the edge.

Heres each raytracing feature’s cost/best settings in opinion on an rtx2060 from my experience.
Shadows from point/spot/rect/directionallight: Low, no settings need to be tweaked here, keep an eye on source radius here
Shadows from skylight: Currently broken. Use AO instead for the results your looking for.
Translucency: Currently mostly broken, reduce refraction rays to 1 and turn off refraction to get any use out of this.
Reflections: Medium, Only use 1 bounce 1 sample, with use reflection captures to hide the fact its 1 bounce (Set up your reflection captures without rtx temporarily, it makes a big difference in quality.)
Global illumination: Too high. Use at own risk of framerate.
Ambient occlusion: Medium-low, You will need to set samples to 4 to get rid of noise.

I have baked the light setting the skylight on static and the directional light on stationary. People project the shadow correctly but on the internal view they are too light…
At the moment I didn’t use RT

Thanks a lot for your advices!!

Since nobody ever replied to this I thought I should add a comment here on why this happens.

If the assets you’re using that appear too bright are set to moveable, it might be the volumetric lightmap being too spares to interpolate enough samples.

Go to Show > Visualise > Volumetric Lightmap, and if the spheres are spread too far apart, that could be your problem. From what I can tell (And I’m no expert) each sphere is a sample that is used to interpolate the lighting that a moveable object should be receiving. Too few samples and you’re likely to get objects that are too bright or too dark.

Go to world settings and lower the “Volumetric Lightmap Detail Cell Size”. I have a good machine and find going down to 100, then 50 if it’s still not helping to work for me. Adjusting volumetric lightmap settings can seriously negatively effect your scene though, so place a Volumetric Lightmap Density Volume in your scene to control wher ethe detail is. Oh, and for some reason that volume works the OPPOSITE of how you’d imagine. Where you place it will receive LESS samples, so place them around unimportant areas.