Download

Baked lighting looks really bad, please help.

I’ve highlighted the issue in the screenshot below, it just doesn’t go away. I’ve tried changing Lightmap resolution and Generate Lightmap UV for each of the meshes and rebuilt but it makes no difference, please help!

To be more clear about the whole scene you should upload more screenshots with informations about the mesh, the lightmass settings and so on.

Hi!

Are you using modular pieces for the wall? …do you have overlapping areas by any chance?
Are you using reflection captures? I see you’re using SSR… could be that it’s bad reflection…

Here you go, i hope this helps!

Yes, the assets are modular, and I try to snap everything perfectly to each other so there should be no meshes overlapping, at least not where it’s visible to the player.
As for reflections, i don’t have any reflection capture in the level, and i checked my post process volume and there is no reflection of any kind turned on.

Modular pieces tend to get a slightly different shade with baked lighting. I’ve “solved” that problem with increasing the quality settings.

You could try to set the Static Lighting Level Scale at 0,25 and the Indirect Lighting Quality to 4. (Best practice: Both values multiplied should add up to 1).
That will increase your build time though. :rolleyes:

Thank you! I played around with the values you mentioned, and i found Scale: 0.1 and Quality: 10 gives me the best results and makes the shading issue way less noticeable. However, this created another issue with the shadows of some of the props looking really rough. I tried messing around with the shadow settings of the lights and the lightmap resolution, doesn’t seem to make a difference. What do you think?

Did you set the Indirect Lighting Smoothness to a higher value while testing? Wildly messing around with different values at once
sometimes causes weird problems :smiley: Maybe the Lightmap resolution of the table, the settings of the light source itself, … again a whole lot of things could be the problem.

Best case would be to go back to the default settings and only change the two values (0,1 Scale and 10 Quality).

Noted, thanks for your help!

Heres part of the solution, turn down smoothness and have things that should not shadow static not cast static shadows.