Download

Baked lighting has light spots

Hi i am trying to bake following scene:

78bda871cd748e7e437dd2b42c8c08abc77cd387.jpeg

And as you can see the buckets has some extremely poor baked lighing on them
They have a basic material with a grey color, and a roughness of .3.

The wall and the pallets below also suffer form these spots.

The room is a 8 x 12 m room with two point lights placed in it.
The outside has the basic setup with 1 sky sphere, and 1 directional lighting.

They have a lightmass of 256, and there arent any UV’s overlapping, and everything in the scene is static.
The shadows from the neighbouring objecs are rather decent.

Anyone has an idea to what causes these spots?

Ty :slight_smile:

Have you adjusted the lightmass settings at all?
How are the objects separated? Is each bucket a separate object?

The above image was taken with pretty much the basic lightmass settings.

All buckets is a seperate static mesh.

I tried fiddling around and a better result, but still with fainter spots, using these ligtmap settings. However these settings now give the pallets almost light up in between them, as if the wood reflects a strong red color.

Elevator.jpg

Currently trying to figure this out too. Any solutions?

I can see that you are not using atleast the 4.18 version of the engine which has numerous changes to the lightbaking system (its a lot better!). Are you building lightning in production quality? Also since you are using older version of the engine, try with 5+ indirect lighting quality, lower the Indirect lightning smoothness to 0.6 and set the diffuse boost to 1 inside lightmass settings.

Actually figured it out, I was doing a flash type render and putting the light source inside a box was causing it. Deleting the box and leaving the light source alone fixed it. Here is the results…

I was having the same problem of bright spots and narrowed it down to a particular point light that was located very close to a bright object (an exit sign), which was probably catching a lot of it’s initial bounces. The light also had Indirect Lighting Intensity set to 4.0 which was exaggerating the problem. Several things can help fix it:

  • Set DiffuseBoost to 0.0, or turn off CastShadows, on the bright object (either will stop it contributing to that light’s bounces)
  • Move the light further from the bright object
  • Keep Indirect Lighting Intensity set to 1.0 and use an additional point light to fake the indirect

I think this is probably more likely to happen the more bounces you have, too (the threads I’ve seen with this problem, both have indirect lighting bounces set quite high).

Lightmass_bright_spot_fix.jpg

Thanks @Spoondog! I was struggling over this exact issue and the solution of setting DiffuseBoost to 0.0 on bright objects close to the light sources works great.

Also thanks @Spoondog I was just having this same issue, and zeroing out the diffuse boost on nearby geo got rid of my sparkle situation.