Baked light lost on force surface mesh after rotation


i have problem similar to this post Baked light bug after rotation - Unreal Engine Forums (sorry i didn’t know if i should resurrect or make a new one).

I am making an augmented reality app i need to rotate the mesh that is shown.
I am on mobile and i need a good quality (and fast) so i can’t use dynamic light (we tried, the result was bad).
The light seems lost around 150°, but it’s getting darker before. The dark part of the object don’t become white.
I can move the mesh (100000 on each axis) and it keeps the light, only the rotation is breaking it.
The light come back when the rotation get closer to 0° (or 360°)
If i bake the light when the rotation is at 180° and put it at 0° after i lose the light.

Does someone have an idea how i could manage to keep the light on an movable object that will rotate (without using dynamic light) ?

You might try baking lighting in your main 3D program into the actual texture of the object and then putting it into UE4 and use an Unlit material. Then you won’t have to depend on the lighting of UE4 at all.

Thanks for your reply, but it’s not possible in our workflow (it would take too much time).
But we found a solution we unticked “use lightmap directionality” in every materials and it seems to work like we wanted.

Any news? Updates?

The OP disabled lightmap directionality either in the material or in project’s render settings. When it’s enabled, incoming light direction vectors are baked into the lightmaps in order for baked lighting to interact with normal maps. When you rotate the static lit mesh, the baked vectors do not rotate, and lighting will look wrong. Disabling directionality will also generate simpler shaders, improving performance .