Download

BAD quality on Planar Reflection in 4.18

In 4.16 planar reflection image was crystal clear, but in 4.18 you can see how it cannot handle AA even with screen percentage set to 100.

Here’s images where you can see the problem:
http://player.fi/planar.jpg
http://player.fi/planar01.jpg
http://player.fi/planar03.jpg

Here’s planar reflection settings on screenshot: http://player.fi/planar04.jpg
(Anti-aliasing not enabled in settings-screenshot, but some reason there’s no any difference if it’s enabled or not… I have tried to keep it enabled also)

I have also try following rendering settings from project:

  • Deferred- and Forward Shading.
  • Temporal AA and MSAA
  • Different values for reflection capture resolution
  • Reduce lightmap mixing on smooth surfaces

Material behind the planar has ofc planar reflection enabled and I have also tried to use high quality reflection setting.

Is this bug or am I missing something?

Try to enalbe both Anti-aliasing and TemporalAA from planar reflection settings. Also you don’t need any Extra fov.(you don’t have any normal distortion) This just wastes resolution at borders and will cause some aliasing.

TemporalAA should handle aliasing from mirror reflections even when planar reflection actor have them disabled.

I have tried to enable both, does not help.
Extra fov is set for the VR.

Unfortunately, I don’t think there is a solution for better planar reflections. It looks like they’ve been downgraded (aka “optimised”) in recent builds.

Use of planar reflections produces quite a drop of performance when used, this in all versions of UE. I can say that if it is not used for glass or water, it is not suitable for VR, since you need at least 90+ FPS per eye, and it looks like you are using it with all materials. Which is the concept behind these reflections?

I used PlanarReflections for my VR Project as well. I used them for glass walls and I’m pretty satisfied with the quality. I will attach some screenshots (scene and settings).

Maybe try using my settings and see if this works for you.
I got a pretty stable framerate, even with multiple planar reflections in one scene (most of the time around 90 fps, and this is with GTX 980 at my “old” office workplace).

Hope this helps :slight_smile:

Perfect quality over framerate is desirable when you are making arch-viz animations or just Cinematics - framerate is not important, because the final output is an image sequence / video.

I do agree with you, thou OP stated he is using for VR…

Some workaround that makes antialiasing smoother in my test scene: console command: r.PostProcessAAQuality 2

Hello, I’ve been toying around with using UE as well, the planar reflections seem to be seriously downgraded. The quality is extremely bad, even when maxing out settings like screen percentage, it looks like both the resolution and AA took a hit. It makes the rest of the scene at odds with its reflection, especially if it is highly detailed. Jagged edges everywhere, it’s insufferable.

Evermotion suggested it used to be better, so I am thinking there must be a way to revert the changes in the code, but before I dive into that tomorrow, does anyone know of a way to do it through console variables? r.PostProcessAAQuality didn’t really get me anywhere. Cheers.