Bad Mesh when importing FBX

Hi,

When importing an fbx file from blender, it imports it with a very bad quality. how can i fix this? Would love to hear from you!

Hi, I guess it is either set to create auto LODs. That’s having low res versions of the mesh for viewing it from the distance. Or it could be Nanite is active and you need to increase the quality settings for it. It’s one of the settings near the bottom of the Nanite options in the mesh browser.

it is a nanite problem. When i import the model with “build nanite” i get the problem i described. When i don’t import with nanite, it shows it in good quality. Do you know how i can fix it or is it just a limitation of nanite?

1 Like

I’m not entirely sure what is happening. I have the same problem with some meshes. Setting the project settings to use DX 12 seems to improve it a lot. (Project settings / Platforms / Windows).
Another way is to set the Fallback Relative Error to something less than 1.0. But that would mean that it uses the fallback of the mesh which it really shouldn’t. So why do we see the fallback mesh? Maybe because of the material used? I’m using some sort of masking within the material. Maybe Nanite can’t handle this? I don’t know.

Anyway - setting the fallback to 0.25 fixes most errors for me. But there is something else going on here.

1 Like