Download

Backlit Light Bleed

Hey,

So the model in question is more a less a plane, with normals on, there are slight extrusions for the bar where the bolts lie, otherwise its a one sided plane:**Mesh showing Material

The issue In engine is where any light hitting the back of the face, Whether its a two sided material or not, causes this issue, here is a shot of it in a Hallway: **Mesh In-Engine Showing Problem **Backshot of Same Mesh

Here is a shot of the other side of the hallway using the same meshes, but not being hit by the back light ( In this case: Directional Light ) : **Otherside of Hallway

The Issue is also noticeable on the Support mesh which is a complete full sided model : **Support Struct Model with similar Issue

Any idea why this is?

P.S.

  • All Models have two unwraps
  • Happens whether material is two sided or not
  • Happens with ANY LIGHT SOURCE if stronger than the otherside

Close-Ups Of the Issue:
http://puu.sh/8syEL.jpg
http://puu.sh/8syG0.jpg
http://puu.sh/8syGT.jpg

If there’s any part of a surface that’s on the outside then parts of the lightmap can bleed onto the interior, since a pixel might be on the inside and the outside it gets illuminated. The way to fix it is by either making sure that none of the surfaces appear outside, or to increase the lightmap resolution. Sometimes increasing the lightmap resolution won’t fix it, or it’s not preferable.

Thanks for the quick reply Darth,

I was playing with the Cascaded Shadow settings they seem to have helped adjust it but along with Shadow Bias just cause a world of issues of their own anyway,
So it seems the only fix for this would be to make sure the only External Light is specifically and carefully placed?

E.G. Spot lights instead of a Directional Light?

P.S.

Have also noticed that the lighting builds differently whether the Directional Light is Static, Stationary, or Movable
Static: http://puu.sh/8sFi8.jpg
Stationary: http://puu.sh/8sFmB.jpg
Movable: http://puu.sh/8sFnu.jpg

If you aren’t moving the light or the meshes then you need to use static lighting, and increase your lightmap resolution on your meshes. And then make sure that no surfaces are extending to the outside and their borders meet each other exactly.

I would like to have moved the light, but the light bleed for that is absolutely insane, Static seems the best way, but I do get some really crappy shadows on most things, so more lightmap resolution increases.
Unfortunately increasing the Lightmaps doesn’t help even to something silly like 1024,

The meshes do meet perfectly, they Clip the camera at the same angle as I intersect two next to each other, what do you mean Extending to the surface, the only faces that are are the backs and the ones designed to, otherwise its all Flush:
http://puu.sh/8sPCZ.jpg

Unsure why Static lights render the back faces pure black but it does help thankfully, perhaps deleting the other back faces will help on Static too…

I could be wrong, but I think this might be a precision problem with the shadow mapping. The first thing you should try is increasing the thickness of the panels (i.e. give it some volume instead of having a plane).

The Plane isn’t as big an issue and seems to fix itself on Static lighting but the fact the THICK Support Beam still leaks light is confusing and just hard to remove, without removing the light entirely.
Perhaps some light ( Or Lack of ) can be shed on this, as to why it bleeds under,

I have tweaked some of the Shadow Bias and other settings of the Light Attached to that Blueprint, it helped with some issues, but otherwise its just the same,
Is our way of designing flawed? or are we just limited to certain locations for our light sources?

http://puu.sh/8tnSH.jpg http://puu.sh/8to6j.jpg

I think your biggest problem is using single sided planes. Try making everything double sided mesh and see if that fixes so of your problems. UE4 can handle quite a bit of polys, its your materials that you need to watch out for so do not be afraid of using to many. You can always pull back if you need to.

Thanks for the Advice there Sam, It may be worth our while just extruding it outwards and hopefully get a much cleaner effect,
We will try that,
Also fixed the issue with the Shadow and Lighting under the door, I just need to make sure all my blueprint Lights have adjusted Shadow bias and such, Perhaps I should push those our as variables to the blueprint to fix individual issues in certain places

thanks guys :smiley: