Download

Awkward Normal Map Rendering in Unreal

Hello, Unreal Community

Below I have my problem displayed; I don’t really know why the normals are rendering so weirdly. I’ve tried exporting the normals directly after baking them fresh in Maya, I’ve tried exporting them from different formats in Substance Painter, and I’ve even tried flipping the green channel in Unreal. It’s definitely a normal problem though because when I unplug the normal map component, the shading corrects itself. Also, it has something to do with the seam around the objects, as you can probably clearly see from the picture. Help? :slight_smile:

Hi,

probably the texture is not imported as normal map (You can check this in texture editor)? Can you show an image of the normal map and / or the material setup?

Kind Regards

freakxnet

Looks like your right. Though I can’t switch the texture to a normal type. Do I literally just have to take the picture into photoshop and add more blue pixels?

Open the texture in Unreal Engine, change it’s formatting to Normal Map.

Check the settings here:

Compression Settings => Normalmap
sRGB disabled

In Material set the sampler type of the texture to “Normal”

freakxnet

You may also want to check how you are exporting the image from your DCC app. I had a very similar problem with the normal map at the UV seams. Please see this thread for the (short) discussion:

Sorry, forgot to reply my thanks. So, thanks! All of this info was helpful.