Avoid savegame Overrides on Build and Run - Meta Quest 2


As a continuation of this question Keep save games without a new package build over writing them?

How do I proceed, if in this case, everytime I try to build to quest… It gives me an error that only lets me complete a build and run if I delete my project app from the quest folders completely…

Therefore, making it impossible to update the app, without having to basically re-install it completely and losing savegames in the process…

Also, before this… I rebooted unreal engine and the oculus quest several times, and everytime i boot up again and build it back (if the build and run doesnt fail and I have to delete it manually from the quest), it ovverrides the savegame once again and everytime.

Hs this happened to anyone else? If so, how do I proceed from this?

Thank you!!

Hi there,
Are you following the steps for patching using the Project Launcher or simply re-packaging your game?
Take a look if this video can help you out.
Unreal Engine 4 Good to Know - Making A Patch File - YouTube

1 Like

I tried doing this, but I 'm trying to make it work for the quest 2 and it simply doesn’t deploy anything to the quest.

It does the pak file, starts packaging normally… but after doing this the app opens completely black.

Hi there,

Thank you for updating. As you’ve mentioned the level starts black, here is my further questions to help me understanding your setup:
->Is this black screen happening the first time you package you game? Or only after the patching?
->If not, have you assigned a starting level correctly in Project settings, “Maps and Modes”?
->Is the starting level’s directory correctly mapped to be cooked? Also, are all relevant maps listed to be cooked?

If all packaging settings were setup correctly, which I’d assume you did, perhaps it is something very specific to Quest 2. I’ll see if I can find anything helpful to share with you.

1 Like

Hey! Thanks for the immediate response!

1 - This black screen only happened after I tried this paching method. Otherwise it works normally

2 - Yes, I only have 1 map and I made sure It was correctly assigned.

3 - Also yes, all maps listed.

Probably, because in the video you sent, he explains it for windows… He has a “windowsnoeditor” on one of the selections he does… There’s no such thing for android

Also, he basically ignores the deployment section… Idk if for quest 2, even tho it’s a patch it still needs some sort of deployment(?).

I’m a bit all over the place, newbie here! I’ll keep looking aswell!

Thank you for your help!

Hi, I hope you’ll find the solution soon. That video is old and yet the best one I could find. Unfortunately, the author states that video is not a “full patching tutorial”, so, yes, there are missing steps for the whole workflow. I’ll see if I can find an updated version of it.

1 Like