Download

Automotive materials crashes after adding to skeletal mesh - UE4.26.1

I have very weird problem. After adding any automotive material (free materials pack) to any skeletal mesh in UE4.26.1, I get errors and material can’t compile anymore. No matter how and what kind of skeletal mesh I add (It can be very simple model - 2 cubes+1bone or just simple box imported as skeletal mesh) the result is always the same. In Ue4.25.4 , everything works very well.

Continue…

Another way to fix this error is to enable with check the last item in each Material Instance: “USE OBJECTS UVS” .
But ou need to do this in all wrong material instance, because of assign the master material to seletal mesh.
I hope this can help you.

Dear Lukas. I have this same issue and to solve it, i get the new demo CarConfigurator. There are two new material for working with Skeletal Meshes: Textile and Opaque.
If you used the version of this shades came with Automotive Material when you assign any material instance of this in a skeletal mesh, your material will get error and to not show.
Sorry the english. Bye

I have the same problem.
in one scene I have a rebuilt engine then a skeletal mesh. as soon as I assign an automotive material it goes into error and ruins all the instances that refer to that master material. who was a master opaque. to solve the error I had to remove the instances from the engine and physically go to the master material folder to replace the corrupt file. then I restarted Unreal and everything went back to normal. There is a solution? as they did in the demo since the machine was riggata and so I imagine a skeletal mesh?

automotive [master] materials are broken as far as I can see in 4.26.

tried fixing with turning off M_Opaque_Masters Usage with Skeletal Meshes [mine are applied to statc meshes] but it keeps reverting. made a copy of this master and used that as parent for my instanced materials although that too is now doing the same thing…

thing i read somewhere this is resolved in 4.27 but would be nice that it worked in this stable release.

Hey, interested in this fix…
what was the corrupt file you replace? are we talking the M_Opaque_master asset?

thanks for any insights as i have this issue. no sooner i try to turn off the Use with skeletal mesh flag in the material as soon as i save/apply it turns back on, in both the original and my copy of it.

Thanks

my fix for this was> create a new map and place a primitive in the scene. before applying a material from the pack to the primitive I went to the M_Opaque_master and removed the flag for ‘Use with Skeletal Mesh’ under Usage of this material. saved/applied the material and then added a instance of the automotive pack to the primitive.

then i returned to my main level where it was broken and the instances applied on my geo now worked [although you might need to toggle of either the is metal., use object uvs, or anisotropy to get it to recalculate and display the correct material.