Download

Auto generate UV map from 3ds

I cant seem to see an UV lightmaps when I am importing from 3ds. Both channel 0 and channel 1 have nothing (see screenshots). I have changed lightmap resolution but still doesn’t do anything. Any thoughts?Capture5.PNG.jpgCapture6.PNG.jpg

Are you seeing the uv maps in your modeling package before you export? Also, ensure it is in the correct quadrant before export. Anything outside of quadrant 2 won’t be seen in the editor.

Thanks for your response JonF.
I am pretty new to all this. Do I need to create a UV channel in 3ds max before importing with the auto generate lightmaps? Not to sure what you mean by the second comment sorry.

You need to create at least 1 uv for the first channel. UE will use that to create the second channel used for lightmaps

I have a UV channel as importing from a different 3D modeling program. when I import to UE4, I have channel 1 created but I can’t see any UV’s and when I build lighting, the object is still black.

CaptureUV.PNG

That section you see there on the right is the Build Settings–these are settings for importing the mesh which include the ability to automatically generate lightmap UV’s, by default the option is enabled when you import a mesh, it will use the UV seams on the first UV channel and flatten it to the second channel and assign that to the lightmap.
What you need to do is that you make sure that the second channel in 3ds Max has your lightmap UV’s and then export to UE4, on the import screen uncheck Generate Lightmap UV’s and then it will automatically use your second channel for lightmaps.
To change the resolution you need to scroll down past the Build Settings there and find Lightmap Coordinate Index and lightmap resolution and that will be the settings you need to check and adjust.

Thanks very much darthviper107.
So I did that and it worked great for 1 element. I found script that can automatically unwrap and flatten UV’s as I have alottttt of objects. The problem seems that when 100+ objects have UV’s attached, 3ds max wont export. Says that it cant create it and nothing in the log. I will direct this to 3ds forums but has anybody found this issue or know of a work around or know if there is a simple way to do it?

Have you tried breaking up the objects?

Hey, I actually also have that export problem from time to time. A restart of Max is normally enough, and if it is still not working one of your objects might have a name that is too long or too complex (happens a lot with CAD imports).

This actually happens to me sometimes. I solved it by importing it again - not by clicking “reimport”, but by right clicking an empty space in the same folder, clicking “Import to (this folder)”, the selecting the same model. It’ll ask if you want to replace it, click yes and it should import with correct UVs.