Auto exposure speed settings don't work properly!

Hi guys.

It’s been 2 days I’m messing with post process volume settings, and when I came to auto exposure, I noticed that ‘speed up’ and ‘speed down’ settings don’t work properly (at least for me). I noticed that the ‘speed up’ setting is adapting quite fast, no matter how much you lower the speed (the change in adaptation is so faint from range 0.02 to 10). But the ‘speed down’ adaptation works way better except one thing which the behavior of ‘speed down’ adaptation is not as quite realistic as should be. When I enter a dark room from a totally light scene, instead of having a very short stop in full black and then a continuous adaptation, the engine prefers to keep the screen dark for quite some time and then suddenly start to gradually fade in (based on ‘speed down’ value).

I think the speed down adaptation should follow an equation like this: L=tanh(t*x-2)/(2+U) +(U+1)/(U+2) where t is time, x determines the ‘speed down value’, L is the percentage of the scene average brightness at full adaptation and U is a non-negative value that determines the difference of the average brightness of the two scenes which calculates each frame. Actually this is a mind equation but should give a good approximation.

I have set the scalability settings to cinematic and the method is set to ‘auto exposure histogram’. I’m using UE 4.15
I hope you guys find a solution to this issue soon.