Download

Augmented Reality for UE4

Any plans to release full documentation or the template? It seems if you change the most basic thing the entire project breaks.

I’m trying to switch out the motorcycle, which I’ve done. However the colours are controlled through a custom variable called Harely which only seems to work with the bike. I will be looking at more closely to try and figure it out.

Hi,

That code is for iOS only, it won’t have any effect on the android.

Only the camera image is upside down or the UI too ?

Also please checkout in project settings -> android -> orientation (Landscape and Portrait is supported by the plugin)

ah thanks, i see. I missed that in the codse, but you are right. And i changed the projectsettings. I tried them all, ReverseLandscape works :slight_smile: Great, now i can start playing with your plugin! But still, when i want to play this project on other devices, then it will be upside down unfortunately. Do you know i can change this landscape into reverse landscape and vica versa in the (level)BP? Then i can make a button/ option in the widget to toggle between these two options.
I tried also the option FullSensor, that seems workong too, it flips to the right modes, but then the view is all stretched out. So probably the first option with the widget will be the best one.

Hi guys, any one can help me with this error code? I can´t launch the AR toolkit on mi S7 device. NOTE: According my android studio, i have installed the android 26 on my pc

LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: ERROR: C:/NVPACK/android-sdk-windows/tools/android.bat failed with args --silent update lib-project --path JavaLibs/downloader_library --target android-26
LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)
LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 6.254448
LogPlayLevel: BUILD FAILED
PackagingResults: Error: Launch failed! Unknown Error

Thanks a lot.

It looked so easy when i downloaded the free demo version. But it pretty dissapointing unfortuntaly. Its not easy get the whole thing running. Now i got it right, it worked. And suddenly the app wont open anymore. Cannot run it anymore. And the weird thing,… sometimes it opends and runs the app! As if the program is not stable?! All other apps and exports work. Probably a result of the pre-compiled version.

Please send me the full log to info@unreal4ar.com

Any error in the logs ?

Also please try to disable the following plugins in UE4

  • OnlineSubsystemNull
  • OnlineSubsystemUtils
  • OnlineSubsystemGooglePlay
  • Android Media Player

thanks again, i tried a lot today again. Igot no errors in the log anymore :slight_smile: It seems that the license was again a problem. And another problem which set me on the wrong track is that the launch failed on my nexus5 phone, but on a samsung it did work suddenly, and kept working. So the settings and license is okay right now. But how in earth i can get the app working on my Nexus. It doesnt fail the launch,… it simply doesnt play the app (it stops after the splashscreen). Do you think this is fixable in any setting? (it only happends with the launch out of the AR template, all other projects launch perfectly to my nexus phone)

edit: works on the nexus5 too!Seems that the nexusphones are very quick with troubles. But once you empty the cache it works again. Now i got this great plugin working on all phones without troubels. Only thing is that some phones need to play it with the reverse landscape. Trying to get that in the BP, to toggle between lthese andscape-types.

Hey there, I’ve been working on getting this plugin to work on top of Apple ARkit, but I’m hitting a block with conflicting spaces.
At the simplest ‘just get it working’ level I want to find the location of a marker, get the screen space location, and cast an ARkit hit test from that screen location, assuming that the result will be correct as long as the ARKit tracking has had enough time to initialize. From there disable the marker tracking entirely since the object can be held in place through ARkit. Anyone know of a way I could move forward with this? Is it even possible to have this work on top of ARkit in that way?

I am using ArPlugin version 1.7. I can not run this plugin in version 4.15. can you help me

Hello,

You need to compile the plugin before you can use.

Please check out the following URL!
http://www.unreal4ar.com/getting-started-full-version/

Hello,

I really like your plugin and i test your demo version for unreal 4.17.
I want to change the Hiro marker to another one, but this dosn’t work. I use the Hiro marker as reference and only change the Hiro letters to Test. So the size of the border and the size of the whole texture is the same.
I did the same like you have write it here.

"The plugin works with multiple markers simultaneously. You could check out the simple demo (the one with chairs), it uses both the hiro and kanji markers.

You need to do 2 things in order to work:

  1. Copy the marker file to \Content\ARToolkit\Data\ as patt.YOUR_MARKER_NAME
  2. Add YOUR_MARKER_NAME to the marker enumeration.

You should also check the output log to see if the marker is loaded successfully. "

When I start the game, the engine give me the error output “unable to load marker MyMarker”

I am really happy if you can help me. (sorry for bad english, i hope you understand me ^^)

I have 2 questions (Using the personal license and unreal 4.18.2).
I’ve succesfully build my app for iOS and Android but still have 2 problems.

I am also using NFT markers!
1: I can not find good filter settings or the object is to shaky or the object is more like floating instead of staying there.
2: It is impossible to set the offset if you turn the camera you need another offset?

please help?

First of all try to use the marker name with low case letters only. So change the filename from patt.MyMarker -> patt.mymarker , also update it in the markers enum.
If it’s still not working please send me your marker to info@unreal4ar.com, and I’ll check it for problems.

Hey Adam,

I’m trying to Start an IOS AR app with ARkit running, initialize and track a marker via ARToolkit for one frame on touch, and then on release turn all ARtoolkit functionality and camera use off and use the found position to project back an ARkit location. This is to get around the problem of both systems wanting camera control. Does the cleanup blueprint function completely disable the plugin’s use of the camera, or does it rely on the app closing to take care of that automatically? Does anyone know if it is possible to Run ARkit for just one or two frames and then return all functionality back to ARkit?

Hello Adam!

We bought and are using your plugin to show a large object like a plane map.
We have some c++ skill and we would like to know if it’s possible after the camera as seen the marker and placed the object. To continue to have it placed at the same location still using the motion of the tablet even when it losts the marker ? (instead of having all the positions reseted to 0,0,0 when it losts the marker)

Don’t hesitate to tell me if that’s not clear.

Thanks in advance,

Denis

Hello Denis,

If the marker is not visible, the plugin can’t determine the position and rotation of your object. That would require some advanced tracking capability like SLAM which is not supported by ARToolkit.
What you can do is to store the last non zero vector position/rotation of the object in blueprints, and once the marker becomes non visible use the stored value to position your object.

Yes I can place my object that way but when it lost the marker the object remain in place but always in front of the camera and it seems like it’s not using accelerometer & gyroscope anymore.
Do you think it’s possible to achieve something like this, based on your plugin?
Thanks again,

Denis

Adam? sorry my comments are very late with being approved