Download

Augmented Reality for UE4

Hi everyone, what do I do if I want to make sure the model is an appropriate size I want? AKA, how do I do unit conversion between UNREAL and the real world? Thanks!

Hey, Adam and everyone. How do I make do unit conversion between UNREAL and the real world? For example, if I want to map a one-inch cube to the real world, how big of a marker should I print and what is the size of the cube in UNREAL?

Thanks,

Hey, Adam and everyone. How do I make do unit conversion between UNREAL and the real world? For example, if I want to map a one-inch cube to the real world, how big of a marker should I print and what is the size of the cube in UNREAL?

Thanks,

Hello,

1 Unreal unit is 1 cm. 1 inch is 2,54 cm.

I would suggest to print the marker in it’s original size.

Hi Adam, im trying the demo version with the UE 4.18 and im getting the white screen when i open the app. I have sent it to google play and downloaded on my tablet.
Is this happening because it is the demo version?
PS.: i dont even know if it is ok to do that, my bad.

Hello Bruno,

The DEMO is only working on windows / mac.

Hi Adam, the template works really good. I like it a lot. I have a question about the using of more Blueprints and more markers. Can you provide us a screenshot of the way you make this in the level_BP?
in the default you have a AR_actor_touch with the bike, and this pops up after the markers Hiro and Pinball. I only use NFT markers. I have 6 other NFT markers, and want them to show 6 different Blueprints (BP_A; BP_B; BP_C,… etc) . But whatever i try, i goes wrong. its harder then i think probably. Now i copy your AR_actor_touch, and drag it into the level, and change the name in BP_B,… BP_C (etc)
My plan was to to this in a branche so that if marker a is seen, then Blueprint a shows. And the if not, it dissapears. Then if marker b is detected, then BP B shows. But i am kind of stuck to get this working in the Level_BP. So i hope someone can provide me screenshot of the way:rolleyes:

Hello. I got the plug-in yesterday and so far I have not been able to get it to work on iOS. I get “Webcam init error”.
This work fine when I press play on the mac, but when I launch it to my iPhone I get a white shape and the error above. This happens with an “empty” project, when I follow the documentation setup. (C++ >> Copy Content >> Rebuild DLL >> Launch to iOS).
Any thoughts?

Furthermore, some of the links on your documentation page are broken Documentation | UNREAL4AR

Hello

It seems the website http://www.artoolkit.org/, anyone knows when it is going back up?
I am looking for the exe that can generate NFT markers and when googling it, it seems that the only source was on this site. Any help would be greatly appreciated

Hello,

I’ve uploaded a copy of the **ARToolkit 5 binary **to the following link:
https://drive.google.com/open?id=1bY…Zl9eJ9BtPGQGqM
(.exe files for marker generation are located in the /bin folder)

ARToolkit website:
http://web.archive.org/web/201802240…artoolkit.org/

Marker training:
http://web.archive.org/web/201802240…arker_training

NFT marker training:
http://web.archive.org/web/201802240…r_nft_training

I hope it helps until the website is online again!

Hello,

Can you please send me your output logs to info@uplugins.com ?

Hello Adam thank you very much for your help, I was trying to recompile and I have the feeling it was not going to go smoothly :wink:

This may help too artoolkit · GitHub

Will there be support for 4.19? Is there a road map to continue development?

Yes! Working on the updated version. I am expecting to release it on next week.

Hi, having problems installing to android device from batfile. What am I missing? C:\Windows>if “C:\NVPACK\android-sdk-windows” == “” set ANDROIDHOME=C:/NVPACK/android-sdk-windows

C:\Windows>set ADB=C:\NVPACK\android-sdk-windows\platform-tools\adb.exe

C:\Windows>set DEVICE=

C:\Windows>if not “” == “” set DEVICE=-s

C:\Windows>for /F “delims=” %A in (‘C:\NVPACK\android-sdk-windows\platform-tools\adb.exe shell “echo $EXTERNAL_STORAGE”’) do @set STORAGE=%A

Uninstalling existing application. Failures here can almost always be ignored.

C:\Windows>C:\NVPACK\android-sdk-windows\platform-tools\adb.exe uninstall com.YourCompany.angela_arplugintest
Failure [DELETE_FAILED_INTERNAL_ERROR]

Installing existing application. Failures here indicate a problem with the device (connection or storage permissions) and are fatal.

C:\Windows>C:\NVPACK\android-sdk-windows\platform-tools\adb.exe install angela_arplugintest-armv7-es2.apk
adb: failed to stat angela_arplugintest-armv7-es2.apk: No such file or directory

There was an error installing the game or the obb file. Look above for more info.

Things to try:
Check that the device (and only the device) is listed with “ADB$ devices” from a command prompt.
Make sure all Developer options look normal on the device
Check that the device has an SD card.
Press any key to continue . . .

edit

Sorry, my bad. I tried installing from wrong directory. I copied the apk, obb, bat files to the phone and tried installing it from there (via my PC) Worked better when I just installed from pc’s directory.

But I have another problem.
When starting the app it crashes a few seconds after showing the splashscreen. Everytime. On both Samsung Galaxy s7 and s8+.

edit2

I get this while installing batfile but it still completes the install. Exception occurred while executing:
java.lang.IllegalArgumentException: Unknown package: com.YourCompany.angela_arplugintest
at com.android.server.pm.Settings.getInstallerPackageNameLPr(Settings.java:5051)
at com.android.server.pm.PackageManagerService.getInstallerPackageName(PackageManagerService.java:27608)
at com.android.server.pm.PackageManagerService.isOrphaned(PackageManagerService.java:27614)
at com.android.server.pm.PackageManagerService.deletePackageVersioned(PackageManagerService.java:23744)
at com.android.server.pm.PackageInstallerService.uninstall(PackageInstallerService.java:991)
at com.android.server.pm.PackageManagerShellCommand.runUninstall(PackageManagerShellCommand.java:912)
at com.android.server.pm.PackageManagerShellCommand.onCommand(PackageManagerShellCommand.java:134)
at android.os.ShellCommand.exec(ShellCommand.java:96)
at com.android.server.pm.PackageManagerService.onShellCommand(PackageManagerService.java:28394)
at android.os.Binder.shellCommand(Binder.java:581)
at android.os.Binder.onTransact(Binder.java:481)
at android.content.pm.IPackageManager$Stub.onTransact(IPackageManager.java:3211)
at com.android.server.pm.PackageManagerService.onTransact(PackageManagerService.java:5073)
at android.os.Binder.execTransact(Binder.java:682)

Hello Adam. I’ve received the information that artoolkit.org is presumably dead for a long time (forever?) but the new support for the framework can be found here
http://www.artoolkitx.org/

Great! I’ll keep my eyes on this.

Hi everyone,

I am pleased to announce the latest version of the plugin!

AR Plugin V1.11 - 2018-03-22

  • Updated for Unreal Engine v4.19
  • Added support for Android 8 OREO
  • Added support for Visual Studio 2017
  • Android camera bugfix
  • Plugin compatibility fix
  • Minor bugfixes

Available on http://ar.uplugins.com !

In case you have already purchased the plugin you can download the latest version from your account:
http://ar.uplugins.com/my-account

If you did not create a user during the checkout process send me any email with your # order id to info@uplugins.com and I’ll send you a new link.

I’ve been trying to install the ARToolKit so I can get at the NFT training tools. Every version of the toolkit I download says to use the installer executable but none of them seem to have one! Am I missing something? I’ve downloaded about three different versions and they all tell me to use an installer.exe that doesn’t seem to be there