Attempted to access missing property after updating to 4.11.2

I’ve recently updated our project to the latest version of UE (4.11.2) and just ran into a weird behavior which I’ve managed to reproduce from scratch:

I create a room containing a FString RoomName.

#pragma once

#include "GameFramework/Actor.h"
#include "RoomBug.generated.h"

class DNRTEST_API ARoomBug : public AActor


    UPROPERTY(Category = "Room properties", EditAnywhere, BlueprintReadWrite)
    FString RoomName;

	// Sets default values for this actor's properties

	// Called when the game starts or when spawned
	virtual void BeginPlay() override;

	// Called every frame
	virtual void Tick( float DeltaSeconds ) override;


I then create a blueprint inheriting from this class and do absolutely nothing in it, just place it in the scene.

I try to display the room name in my ThirdPerson blueprint

It works great, until I modify anything in the RoomBug.h file I always get the same error (after compiling and launching project). And by anything I mean anything, just adding a comment anywhere in the file, adding a variable, adding a carry return will break the thing. The only way to get it back is to CTRL + Z and delete + recreate the blueprint part in the ThirdPersonCharacter.

I’m a little confused and don’t really know if this error comes from our code base or if something broke while updating to 4.11.2. I’ve tried reproducing the bug with the exact same project in 4.10 but everything was working as intended.

Thanks in advance for your help

Edit: forgot to mention I’ve been getting a lot of messages like the one below after upgrading to 4.11.2. I fix it by compiling the BP before saving, which seems to solve the problem temporarily


I had the same issue. Mine occured with accessing an inventory menu which had its visibility dependent upon a reference to an ESlateVisibility variable from my player character cpp file. It is without a doubt a blueprint-related issue, but it may more specifically be a Slate-related issue. I fixed mine by fiddling around in the event graph of the culprit blueprint.

Hopefully it’s a temporary issue with 4.11.2, but for the time-being it seems you’ll have to delete and recreate the reference variable in the blueprint any time you modify the referenced object.

Try deleting your “Ref” variable after modifying the .h and then recreating it, and let me know if it works after that.

Thanks for your answer! I’ve actually posted a bug report about this, Doug W. confirmed it was not a normal behavior and told that recompiling the BP fixed this error (which it does)

The bug report thread

This is somewhat old, but I had the same issue after an update to 4.20.
It helped me to delete the reference in question and re-insert that get variable into the BP.