Download

Atmosphere causing color banding issue with skybox

Hey everyone,

I started having this issue with the blueprint skybox actor and the atmosphere fog actor the other day and I’ve never had this problem before. Our level designer opened up our map and is seeing the same issue.

I’ve made sure there is no duplicate skybox, ive set all of the properties back to default on the atmosphere, and replaced the atmosphere actor with a new one.

i have two gtx 680’s and the drivers are all up to date.
Bug_skybox.JPG

I’ve had this, it appears that fog (specifically height fog) doesn’t work correctly at vast distances. I fixed it by disabling fog rendering on the skybox and faking the fog color on the skybox/skydome

I’ve only seen this issue once before, which was caused by having an insane view distance. The fog is based on Scene Depth, and the more ‘depth’ your scene has the less fidelity you get between the min and max distance.

The way around it is to reduce view distance, though the parameter escapes me right now…

See, the weird thing is I haven’t moved the skybox at all, it’s the same distance as it is in the default level.

But I’ll try and play around with both those solutions today and see if they work, thanks guys.

Do you have an ExponentialHeightFog actor in your scene? I ran into the same issue while using both the height fog and the atmospheric fog at the same time, but this was in a custom built SkyDome.

To fix it I ended up removing the atmospheric fog since I was already using a SkyDome, using both is not necessary, it was simpler to just make adjustments to the sky material. But I was able to reduce the effect by adjusting the “Fog Height Falloff” in the HeightFog, or if that still doesn’t remove it try adjusting the various Offset & Scale values in the AtmosphericFog (such as Density Offset and Altitude Scale).

I’m just using an atmospheric fog actor. So I increased the Distance Scale from 1 to 3, and that seems to have, for the most part, solved my problem. The banding IS still there, but it would only be noticeable if you were REALLY looking for it.

I was almost positive I had played around with this setting before, but I guess not :), thanks for the help guys!

So i went ahead and opened up a new level, the default one, and noticed that there is a slight visible banding occuring without modifying anything. I don’t remember seeing this in the default map before, does anyone else have this issue?

Here is what i see when i look straight up, but it seems to disappear when looking down towards the horizon
Bug_skybox_02.JPG

I remember seeing a couple of posts a while back on AnswerHub that may be related to this. Just for reference which version of the engine are you using? Also is it built from source or accessed through the launcher?

Using 4.6.1 and it’s built from source

Just ran into this issue. This was my fix:

Turns out the NearClipPlane value was too low. Original value was 10, I had set mine to 1 which caused the banding. Setting it to 5 or higher fixed it.
From what I understand it has to do with how the z-buffer is calculated. Anyways: huge distances and small clipping plane values => banding.

Some other things that could have fixed this issue while keeping the NearClipPlane value low:

  • reducing the SkyDomeSphere scale

  • increasing the SkyDomeSphere poly-count

This post was helpful: Near clip plane not behaving as expected - UE4 AnswerHub