Download

Assets revert their 'generate lightmaps' checkbox when reimporting

I’ve had issues with changing ‘generate lightmap UV’ while re-importing assets - UE4 does not seem to want to actually set the ‘generate lightmaps’ checkbox unless that was set to True when imported the first time. Am I missing anything? Should I be able to set to this to True if I forgot to set it when I imported it?

I used the send to unreal add-on in Blender if that helps…

Thanks!

I think it reimports with the same settings as initially imported, that has been my experience anyways

Can’t you simply open it in the mesh editor and enable “Generate Lightmap UVs” under Build Settings? There’s a re-import option in the mesh editor too, which if Generate Lightmap UVs is set in the dialog for it, it should do so…if it’s not, then I’d suspect something is wrong with the export file or settings in UE are blocking it somehow.

You’d expect so yes but Steve is right afaik - UE4 looks at the initial setting when hitting re-import. This seems like a bug to me, I can’t image a scenario where you change your asset, then 1 week later you want to do a re-import that includes reverting your changes? Nah.

And to be clear, I do want to change the checkboxes and make that setting stick even if reimporting.

Changing import settings on the asset allows you to re-import with the new settings.
this works 100%. Been re-importing modular custom pieces for over a week. And changing from auto-generated to custom lightmaps along the way. In .25, if you have issue in .26 it may be a bug.