Assets failed to save on autosave and not only


From version 4.17.1 I have errors in my projects. It not happens before, any changes in hardware or other software.
On auto save I have error message like this:

The asset
(FirstPersonExampleMap.umap) failed to

Cancel: Stop saving all assets and
return to the editor. Retry: Attempt
to save the asset again. Continue:
Skip saving this asset only.

This is on fresh created project for test (fps), I had it with my older project too (moved from previous engine versions), I created this project only to check, this is my code problem on engine.

When I’m saving it by button [Save All], any error messages and assets saving correctly. However this is distracting and not safe. And I have other problems with newest version, I’ll post in next thread.

Thank you.

Typically this is caused by the file being marked as read only (because of perforce) and UE4 not realizing this and setting it to write while checking it out from perforce. To solve delete your saved folder and rerun connect to source control.

To solve on a more workaround basis just set the file to not read-only via the windows file system (right click on the file and go to properties in windows explorer)

I have not written anywhere that I am using any kind of source control - I’m not. Folders or some files are marked as read only. I not remember they was before or not, but I not changed anything myself.

Then simply unmark them as read-only?

First what I did, it not helps.

Having this same issue with new projects as well. Seems to only start up when I set things to save on compile.

I have save on compile, but this is how I always had.

Bump - little update. It happens with level set as ‘persistent’. I work last days on non persistent level and this problem was not visible, now I see this is reason. All other assets saving correctly, just map can’t save.

I can still save all (including level) with Save All, problem happens only on auto save.

Hi again. I see it working. This is no bug fix but only solution. I can’t mark your comment to answer and select, maybe because this is comment on other user answer. Dunno. Anyway thank you again.

this solution worked for me, but i am using source control. the error started when i migrated from 4.15 to 4.17. persistent levels would save on demand, but not during auto-save. deleting saved folder fixed issue.

Running into this issue in 5.03 as well. Very frustrating.


A bit late in the party, but had this issue recently with UE5.1.1 same error message, but in my case along with apparently many since 2014 (according to other forums), this happens if you have the same project opened twice. In my case I closed the other copy of the project and it worked.

See this forum: