Assertion failed: NumBytes == Strings.Num()

Hello I get this error:
LoginId:cee055dc4576298d0220d987cadffb96
EpicAccountId:99ce811b69a84e5e89473d80ee2c129d

Assertion failed: NumBytes == Strings.Num() [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/Core/Private/UObject/UnrealNames.cpp] [Line: 3336]

UE4Editor_Core!AssertFailedImplV() [D:\Build++UE4\Sync\Engine\Source\Runtime\Core\Private\Misc\AssertionMacros.cpp:104]
UE4Editor_Core!FDebug::CheckVerifyFailedImpl() [D:\Build++UE4\Sync\Engine\Source\Runtime\Core\Private\Misc\AssertionMacros.cpp:461]
UE4Editor_Core!LoadSeparatedNameBatchInShardOrder() [D:\Build++UE4\Sync\Engine\Source\Runtime\Core\Private\UObject\UnrealNames.cpp:3336]
UE4Editor_Core!FNameBatchLoader::Load() [D:\Build++UE4\Sync\Engine\Source\Runtime\Core\Private\UObject\UnrealNames.cpp:3472]
UE4Editor_Core!LoadNameBatch() [D:\Build++UE4\Sync\Engine\Source\Runtime\Core\Private\UObject\UnrealNames.cpp:3481]
UE4Editor_AssetRegistry!FAssetRegistryReader::FAssetRegistryReader() [D:\Build++UE4\Sync\Engine\Source\Runtime\AssetRegistry\Private\AssetRegistryArchive.cpp:140]
UE4Editor_AssetRegistry!FAssetDataGatherer::Run() [D:\Build++UE4\Sync\Engine\Source\Runtime\AssetRegistry\Private\AssetDataGatherer.cpp:524]
UE4Editor_Core!FRunnableThreadWin::Run() [D:\Build++UE4\Sync\Engine\Source\Runtime\Core\Private\Windows\WindowsRunnableThread.cpp:86]

Its showing only when I try to run exactly one ue4 project.

2 Likes

Hi,

I found this forum thread: Unreal Engine 5 crashes on Start up - #2 by eonridr. It is originally from an Unreal Engine 5 issue, but a few comments into the thread state that the proposed fix works for 4.26 and 4.27. Here is the answer from user Varxon:

This error comes from a corrupted CachedAssetRegistry.bin file. Reinstalling it does not fix the file.
To fix this, you are going to want to go to file location C:\Users\username\AppData\Local\UnrealEngine\5.0\Intermediate - Locate the file named CachedAssetRegistry.bin and delete it. After deleting it, you should be able to launch

Obviously, just adjust the directory to match where this file will be located. I hope this works, and good luck :slight_smile:

10 Likes

It’s not work, but thanks you

That`s worked for me. Thanks!

If another project opens with same engine version then probably the problem is with local CachedAssetRegistry.bin in your project.

SOLUTION: Delete the Intermediate folder then generate visual studio project.
Make sure there no error in your project’s source code otherwise it will not compile.

1 Like

thank you that worked for me

This works for me

IT WORKS. Thanks you so much !!!

Worked on 4.27! Thank you!

This one worked for me 4.27.

Thank you very much dude, I deleted the CachedAssetRegistry.bin from intermediate folder in my project and it worked, deleting it in C:/Users doesn’t work for me.

1 Like

NOTE : if this solution doesn’t work Try deleting the intermediate folder from the project, not from Appdata/…

1 Like

Thank you so much bro

I had this exact same error the OP had and THIS worked! Thank you both, I was sweating!