Assertion error when upgrading plugin from 4.22 to 4.23

i’m unable to upgrade my plugin for 4.23 because of this roadblock. Compiling the plugin doesn’t throw any errors. It is when i run the game with the plugin does the assertion error throw up.

The crash point seems to always be at the module code of the plugin. In my case, its at DragonIKPlugin.cpp


void FDragonIKPluginModule::StartupModule()
	// This code will execute after your module is loaded into memory; the exact timing is specified in the .uplugin file per-module




This is the stack trace leading to the crash

'UE4Editor.exe' (Win32): Loaded 'F:\Program Files\Epic Games\UE_4.23\Engine\Plugins\Runtime\PhysXVehicles\Binaries\Win64\UE4Editor-PhysXVehicles.dll'. Cannot find or open the PDB file.
'UE4Editor.exe' (Win32): Loaded 'F:\Program Files\Epic Games\UE_4.23\Engine\Plugins\Runtime\PhysXVehicles\Binaries\Win64\UE4Editor-PhysXVehiclesEditor.dll'. Cannot find or open the PDB file.
'UE4Editor.exe' (Win32): Loaded 'F:\Program Files\Epic Games\UE_4.23\Engine\Plugins\Runtime\RuntimePhysXCooking\Binaries\Win64\UE4Editor-RuntimePhysXCooking.dll'. Cannot find or open the PDB file.
'UE4Editor.exe' (Win32): Loaded 'A:\Mega Projects\Project20_Plugn 4.23\Plugins\DragonIKPlugin\Binaries\Win64\UE4Editor-DragonIKPlugin.dll'. Symbols loaded.
Assertion failed: GEditor [File:D:/Build/++UE4/Sync/Engine/Source/Editor/Kismet/Private/BlueprintEditorModule.cpp] [Line: 163] 

UE4Editor.exe has triggered a breakpoint.

Can someone help me out here ? I cannot for the life of me even understand why this crash throws up because the entire stack trace is extremely vague. This is related to plugin migration, so this might be common among other plugin developers.


I have the exact same problem with a plugin im trying to update (just a custom IK node, nothing too fancy).

So far I have discovered that if i comment out this line FModuleManager::Get().LoadModule(TEXT("AnimGraph"));
the engine will not crash but then my custom node doesn’t seem to do anything.

Any help would be appreciated.

EDIT: nevermind… commenting out the LoadModule parts seems to work after all… should have tested it more.

I get the exact same error loading PersonaModule in a different plugin. Any update apart from just removing the module load?