Artifact outline on meshes

It’s really hard to see in the picutre, but the mesh at the bottom has an outline at where it’s supposed to be transparent. Any mesh that contains this material has these weird outlines. Our material is simply a masked lit material, and we use pixel art.

We used different meshes all with correct UV’s set up so that’s not it. We tried doing one sided, use transulency, use tga instead of png, etc all to no avail.

Only a few of these have it, the rest do not (such as that bush). The settings are completely identical between ones that have and don’t have, so I am really at a loss here!

The largest pattern we could find is that these artifacts appear more often on textures that are 32x32 (but not always; some 32x32 are fine). How could this possibly cause artifacts like these?

Hey there, it could be that the alpha mask is not perfect on the corners, so it’s leaving a line.

Hmm we’ve used pixel-perfect drawing programs (aseprite, piskelapp, photoshop) and zoomed in to infinity and made sure it was transparent, but they all had the same results.

If you try other materials that have an alpha mask (even if it doesnt fit right with the uvs) do you still have the same issue?

I tried other materials with the same alpha mask and indeed there are the lines there. However, I brought the image into a program an read every pixel’s alpha data and there wasn’t any there. I realize the pattern of them showing up in UE4: if there are two pixels that have a non-0 opacity value at opposite edges of a square, then this line would show up. Can’t figure out why, it’s super weird…

Ok, as I see it you have this problem. Your pixel perfect texture is made from edge to edge and planes are mapped as well exactly and perfectly in UV space from edge to edge.
You have 2 options as far as I can think of:

  1. “fix” mapping to less perfect state, where you leave some space near edges of UV space, so your tiling wont afftect opposite side.

  2. try to open your texture in UE4 and change X-axis Tiling Method to clamp or mirror (I would prefer clamp). Of course Y as well.


Thank you for the reply milki, unfortunately neither of those methods have worked. I had a hunch that the forward shading might be the problem - and yes it was, turning off forward shading solved the problem. I will stick to this for now and hope my performance doesn’t need FS!

Edit: Actually MSAA was the problem, unfortunately I don’t have any other good AA options for VR