Download

ARKit dynamic shadow quality

I’m trying to get sharper dynamic shadows on AR models, but it looks like anytime I change the “Num Dynamic Shadow Cascades” I get some artifacts on my model.

So here is what I do;

  • UE4.21 || UE4.22;

  • New Project -> Handheld AR;

  • Add a Plane for the BP Placeable;

  • Change Directions Light to Moveable;

  • Set Cast Modulated Shadows to TRUE;

  • Dynamic Shadow Distance Moveable to 1000;

Setting the “Num Dynamic Shadow Cascades = 1”, renders real-time shadows, but they are of a very low quality:

​​

Setting the “Num Dynamic Shadow Cascades = other than 1”, produces artifacts like so:

The only way to get a sharp shadow without the rendering artifacts was to Enable “Metal Desktop-Forward Renderer”, but unfortunately this requires A10 processor and even than, the frame rate dropped about 50%.

Am I missing something?

i am having the same issue with the number of cascades and quality.
i have the added issue of the shadows turning on and off depending on the direction you look at the model when having more than 1 cascades.

the closest i have gotten is to turn the depthbias on the light way up, this helps get rid of the lines in the shadow but not the shadow disapearing. but this makes the shadows even lower quality.

we cant use the “Metal Desktop-Forward Renderer” as we cant take the performance hit.

anyone have any ideas?

found something that helped me out
set max. metal shader standard to target to - Metal V1.1 in project settings
only use 1 `num dynamic shadow cascades´ and 0 ´far shadow cascade count´, in light settings.
and then play with the lights depth bias to fine tune the lighting

but the biggest change is the Metal V1.1