ARKIT camera feed is not synched with 3D world


Tried the examples in the ARKit forum threads and (was confirmed by other user) camera feed is lagging a bit behind the 3D world, which kills AR integration. Objects slide, which is very visible even with relatively low speed movement.

See here:

Have you tried this solution?

Thanks for the suggestion.

I have not yet tested as, for an unknown reason, my project does not deploy anymore. Maybe due to xcode9 only being present.

btw, I saw that i could enter the value when app is running, through the 4 finger gesture and console. I have difficulties seeing in what ini file and how to write it down exactly. Any hint or link to a doc? I unfortunately found nothing related to this flag that helped me understand where to change it.


If I only have a couple changes like that then I often put them in code so if I copy-paste elements to other projects, then I won’t miss a setting in the .ini. To do it in blueprint, use this block:

For the command, you would enter “ar.EnableLateUpdate off”.

For the .ini files, there should be a config subfolder in your project. I wasn’t able to dig up much in the way of documentation though. The keywords you’re looking for are “configuration files”:

Thanks for the information. I had those already, but executeConsoleCommand does not work in release, so i avoid it for final (will use it for tests, once i can deploy again)

About configuration files, yes, this is what i looked for. But yet i have no idea of what ini or section i should use.

I will dig more once i’ve finally been able to sort out my first problem, deploy. (have a device not paired error that i cannot pass through…)

Possibly the DefaultGameUserSettings.ini or GameUserSettings.ini?