Download

ARKit 2.0 on Windows

Has anyone been able to launch to an iOS device from Windows on ARKit 2.0? I am just getting the error that Remote compiling requires a server name. I was able to launch on 4.19, but since I update, I am no longer able to.

Hi DMHokie,
I am using Win10 64bit, UE4.19.2 and I’ve been working with ARKit for a week now.
I had a working ARKit project installed on iPhone 8 using UE4.19.2.Yesterday I installed the new UE4.20Preview to check out the new ARKIT 2.0 (new plane detection, better tracking, etc.). The certificate and the mobile provision were okay (GREEN) I launched the app and it asked for Remote Compiling. So I decided to go back to my old 4.19 project and continue working there, because I thought that 4.20 is Preview version and it’s not working well, but the Remote Compiling
error showed even in my old project where I was working all week with no problems. I can’t get rid of the “Remote compiling requires a server name.” error.

Here are the things I’ve tried:

1.I uninstalled all UnrealEngine versions that I had and installed only 4.19.2, again new certificates and provisions, but Remote Compiling still here.

  1. My project is blueprint only using the built-in HandheldAR template no 3rd party plugins.(If you have 3rd party plugins they require Xcode compilation)

  2. I added a script in DefaultEngine.ini

[/Script/IOSRuntimeSettings.IOSRuntimeSettings]

bUseRSync=False

This is suppose to disable remote building. It’s enabled by default. It did not work.

  1. Tried to delete the following project folders Saved, Intermediate, Build and Binaries.

  2. Tried to delete the two rows in DefaultEngine.ini saw that in another thread, but all it does is resets BundleName and BundleDisplayName under Project Settings - Platforms - IOS - Bundle Information

BundleName=ARFactory
BundleDisplayName=ARFactory

  1. In another thread was mentioned that a clean Blueprint only iOS App will work on PC but the ARKit requires a Xcode Compilation on its own, so I made a new project without ARKIT to see if the plugin requires some Xcode compilation and is the cause of the error. Same result it wants the server again. So the problem is not in ARKit plugin because I was working with it a day ago and there is no difference if the project is with or without the plugin

Same issue…my handheld AR project works fine with UE4.19.1/2, remote build works fine too. But not work with the new UE4.20.
-------UE4.20+ios12beta4+xcode10beta4(remote build)------
I can lunch app to my iOS device but it crushed immediately after opened. some thing is wrong. Still working on it…Did u guys success to remote build & launched a new 4.20 empty Handheld AR templete to any ios12 device?
Let’s find out what’s wrong with it. I’m not going to back to 4.19, I like those new features in 4.20.

Actually we never needed the remote build in 4.19
What I don’t get is how a 4.20 update/installation broke a working 4.19 handheld AR project?
Maybe they share a common ini somewhere appdata user (win 10 user) folders idk

I’ve been able to launch a 4.20 project with ARKit 2.0 from Windows (remote build) but the app crashes at startup. Is Xcode 10 and iOS 12 betas required? I’m currently using iOS 11 and Xcode 9 and get no errors at build.

I have an AR app started in 4.19 that works fine when using 4.20. This worked with iOS 11/Xcode 9 and iOS 12/Xcode 10 betas, which is a bit confusing in itself, but all good.

However, a fresh 4.20 project based on the AR template crashes after the splash screen. I initially thought the provisioning/certificate setup was causing this but I’ve checked and all appears valid.

I think we all have the same issue.

It is confusing. I wonder if UE4’s plugin is enabling/disabling features and switching between ARKit 1.5 and 2.0 depending on the iOS/Xcode version. Thanks for letting me know, it seems then my issue should be somewhere else.

Just for the record, I did get an answer from Epic’s staff. ARKit apps with 4.20 will work with iOS 11/Xcode 9 but only ARKit 1.5 features will be available. To use ARKit 2.0 features, iOS 12 and Xcode 10 (betas now) need to be used.

Okay but what is going on with the blueprint only projects that are precompiled in the engine and can be used without Xcode compilation? Why do they require a compilation when the project I am launching has no additional c++ code or 3rd party plugins.

That’s useful info from Epic, makes sense. Thanks for sharing.
Now if we could just find out what is causing our crash…

Would like to know this as well!

Piggy back on this thread; does anyone have any advice for setting up a remote build from Windows to Mac for IOS development specifically for ARKit.
Have a thread open explaining my problems but no luck.

https://forums.unrealengine.com/development-discussion/ios-development/1495144-trying-to-remote-build-on-mac-from-windows-any-help-with-these-errors

I have spent days trying to get it to work, followed Unreal’s documentation and other setup guides around the net but no luck. Forums and Answer Hub is limited.
Using 4.19 and just using the out-of-box Handheld AR template.

I got it working and I think the only issue I had was with assigning the right permissions to the SSH key file. Other than that, it was just a matter of having all the basic setup in Project Settings and standard networking communication happening between the two machines (e.g. no firewalls). What specifically are you struggling with?

After doing some debugging it seems that my crash is related to a change that was done in GPUSkinVertexFactory and not allowing a skeletal mesh to have a higher count of bones. This wasn’t an issue in 4.19. Epic is investigating this.

Thanks for the tips. I plan to circle back to solving the problem soon. I think the problem was getting proper communication between the machines (even though other programs told me I was good to go). It is possible some firewalls were in place and I have to check them out.

Did anyone succeed launch ARKit project (HandheldAR templet) to an iOS device from Windows on UE4.20.x ? Please let me know.

Hello Luoyeshu,

Currently you will need a Mac to remote compile on if using ARKit.

Hi,

Regarding the crash of the application after splash screen, I found that the ARKIT plugin is disabled. you will need to activate it and restart the project.

I`m currently trying to remote build on mac, is there any good guide? the one in the documentation is partial and not working…

Best Regards,
Doron

Its a pain in the ■■■, but I was able to do it, hit me up if you need help on this

Hello,

I am desperately trying to build the the AR handheld template from my Win10 machine via remote build on a Macbook to an Iphone.
(unreal 4.20.3)

I got my certificate and provision file setup and Xcode 10 installed on the macbook.
Sending the xcode template AR project directly from my macbook on to the iphone works. (test of deployment target).

I created an Unreal blueprint AR template project on my PC with exactly the same name as the xcode project on Mac.
Network connection is fine. Rsync is set up on the Mac, as well as DeltaCopy on my Win 10 machine. The SSH key generation worked.
Bundle Identifier in the UE4 ios settings is exactly the same, as in the xcode project.

The problems:
My provision and my certificates are showing both as **valid **in the UE4 ios setting. But aren´t they supposed to be marked as green also?
I imported them directly in the project settings, without the use of IPhonePackager.

When i try to package the project (file/package/ios) or try to quick launch it via All_IOS_ON_… I get:

Provision not found. A provision is required for deploying your app to the device
Signing key not found.The app could not be digitally signed, because the signing key is not configured.

When I try to launch it with the project launcher and select All_iOS_ON_ from there, the build starts but cancels when deploying content for IOS
with an error:

ERROR:System.IO.DirectoryNotFoundException: Could not find file 'D:\Unreal\ARtest\Binaries\IOS\ARtest.target
(there is no binaries folder in my project and therefore no target file)

I tried all day to solve these problems.
What I just don´t get in the first place are the provision/signing key missing reports, since they are marked as valid in my project settings.
And whats up with that missing .target file?

Cheers