Download

Are you unable to package Windows projects in UE5? Fear not, I have a solution for you!

So when I first installed UE5 and tried to package a Windows project I was greeted with this message. If I disregarded it and clicked continue, my project would “package” instantly. Except… it didn’t. It just left me with an empty packaged game folder.

Luckily I have found a solution! So, if you’ve experienced the same or a similar issue, here’s what you need to do:

Step 1

Copy the “hostfxr.dll” file in

“C:\Program Files\Epic Games\UE_5.0EA\Engine\Binaries\ThirdParty\DotNet\Windows\host\fxr\3.1.9”

to

“C:\Program Files\Epic Games\UE_5.0EA\Engine\Binaries\DotNET\AutomationTool”

(important to COPY, not MOVE!)

Step 2

Install the .NET Core 3.1 Runtime (https://download.visualstudio.microsoft.com/download/pr/d30352fe-d4f3-4203-91b9-01a3b66a802e/bb416e6573fa278fec92113abefc58b3/windowsdesktop-runtime-3.1.15-win-x64.exe)

Step 3

DONE! When you try to package your Windows project in UE5 now, the editor will still throw up that previous message and warn you in general that you do not have the proper SDK installed. Just ignore the message. This is most likely a bug. Your game will still package without any issues if you click “Continue” when the message pops up!

----------------------------------------------------------------------------------------------------

It is currently unknown whether you will need to “recopy” the “hostfxr.dll” file every time a new update for UE5 is released (in early access at least). It is also interesting to note that UE4 Windows projects package just fine without having to install .NET Core (or anything really), so I don’t know whether this is intended behavior in UE5, a bug or if someone at Epic just screwed up and forgot to include or point the proper files in the UE5 installation process.

Not sure if I should report this as a bug or not…

If anyone has any smarter solutions that don’t require you to install anything (.NET Core etc.) please share it!

I hoped this helped somebody.

2 Likes

Was having same error and this process is allowing me to package now. Thanx!!!
It’s definitely a bug for sure.

I forgot exactly where, but in the same popup window that you can package your game look for something that says something about fixing your SDK for windows. This got rid of the warning message for me. Just read all your options in the pop-up window you’ll know it when you see it. Hope this helps!