Download

(Archviz)Directional light "powder" artifact

Hi guys,

The lightmass looks fine until the directional is used, anyone knows what cause this error?

*Using GPU lightmass baking
*floor lightmass is 4K
*World lightmass setting:
Static lighting level scale 0.1
Num indirect lighting bounces 100
Num sky lighting bounces 50
indirect lighting quality 20
indirect lighting smoothness 0.25
*Directional light is Static. (also tried stationary, no different but screen brighter)

This is the result of skylight+directional light, with the artifact.

a close up shot to the artifact

Hi!

IMO!
…your setting are extremely high!! Like unnecessary high!! …I won’t even ask you about render times!!
Oh sorry! Now I see you’re using GPU lighmass! Those settings don’t matter at all! It doesn’t uses any of those!! You just need to chose (depends on your version) what quality you want to bake… and set production in the engine…

So I’ve seen these but it’s different in GPU lightmass… and usually they come with point/spot lights (placed too close to geometry), emissive lights (missing portals covering the material) or with HDRI set to some extreme value (intensity, extra GI)… could it be double sided material… those produced things like this in GPU lightmass calculation…

Hi!

yes, I try to do it like extremely high to see if i can get rid of it but make no different :frowning:
The output quality is production and Epic.
Rendering time is about 2mins, not sure, it was a small scene with lightmass importance cube, so even high setting doesnt take long.

There is only 2 lights in the scene, skylight and directional, no spotlight, no rec light at window, no hdri (the window view is just a giant jpg)

Ok, so as I’ve said before: in GPU lightmass NON of those settings matter!! GPU lighmass DO NOT use those at all!! So you can set whatever it won’t make ANY changes!!
All you can do is set your lightmap resolution to get better quality!! …the rest is automated calculation!! Some of the versions had different quality sets but that’s all!! In GPU lightmass there is no real control over the light settings…

Are you using a box or a plane for the floor? Are you using two sided material?
Another weird thing that I just realized: you have the same lightness with or without your directional light!! ?? It should brighten up the whole scene!! ??
What are your lights’ intensity?

Also: might be just the image compression but around the TV, mostly to the left, you don’t have the similar artifacts even before the the directional light?

Just complementing what @Makigirl is saying, since you’re using GPU try checking your lighmass.ini and bump up your NumSecondaryGISamples to 64… Like this:

[DevOptions.GPULightmass]
NumPrimaryGISamples=128
NumSecondaryGISamples=64
FireflyClampingThreshold=10000.0