Download

Arcade Graphics In Widget - Poor Render Quality

Hello all, I’m having an issue with rendering an arcade style speech bubble from a widget blueprint. Im working in 4.10 on windows.

I have created this speech bubble in Photoshop and the imported into UE4.
0a16a0a82b34aa59bd687d605211bdfdac002f4a.png

As can be seen it renders how i would like it to look. It has clear edges and each distinct pixel can be seen.
However, when I add it to a widget blueprint using an image component and setting the brush image to my asset, it suddenly looks like this.
68e57cfd9a57c7c4b5c2f447c7392dcc51eaf118.png

Furthermore if I create a sprite based on the image and add that to the world it renders fine.
My original file is 64x64 and saved as a png.

Does anyone have any idea as to why this is occurring and how I can fix it? Any help is appreciated, thank you in advance.

You should be able to disable texture filtering on the texture properties.

This is found in the texture properties by expanding the extra options under “Texture” and setting “Filter” to “Nearest Neighbor”.

I have found the filtering options for my texture but it only has 3 dropdown options. Nearest, Bi-linear, Tri-linear and Default (from texture group). I’m assuming by nearest neighbor you mean the nearest option. I have already chosen that and as I have shown in the image above, in the texture editor it looks fine. It’s only once it’s in the widget blueprint that it becomes blurry.