[AR] Samsung S8 after upgrade to Android 8 stopped work with UE4 AR apps

Hello, I have Samsung S8 and I have developed the application that was working fine on Android 7.0 (original Samsung S8 OS) and recently a week ago my phone has updated to Orio. I was quite happy about that, I did not pay attention and today I have run the application that was built on 4.18.3, and it did not initiate the camera and just doesn’t show any camera background, just a black screen with some UI widgets. I have run the application that I made a long time ago on 4.17, and it also doesn’t show any camera use.
How to fix it? What’s happen? Why ARCore has stopped to work on the phone, I have not build anything yet on 4.19, but I don’t understand the root issue with this. Should I revert the phone to Android 7.0 (How?).

Epic developers, can you please give some comments? Maybe I have to activate ARCore and probably it needs to ask for some permissions, which it never asked for. I have tested IKEA AR app and that worked no problem on new Android Orio. (As I remember it asked for the permissions to use a camera…)

I just checked in Anrdoids APPS - it has all the permissions for camera, location, storage.

I would also like to know more about this, I have the same problem

Same problem with 4.19.
All works, but the camera view is black.
The app has permission for the camera.

Sony Xperia X, but sadly updated a few days ago.

Only way, it’s to revert back to factory settings, in my case it’s original Android 7. That is very sad no more Android AR anymore in Orio version :frowning:

Hi, Can you guys provide a Android logcat when the app is running? I can help take a look at this.

This is my logcat:

It seems APP itself working fine and even tracking the surface and placing the object, it just doesn’t show cameraimage anymore, BUT still able to track the sufrace, so it means by fact Camera IS working fine, it’s something with outputing it to the screen on S8, Android 8

I have sent my AR development shipping application, I still not able to produce any AR apps on Samsung S8 + Android 8. (was working fine on Android 7)

Any updates?

I have sent yesterday my AR app (development version to Bo) and I waiting for the reply. I hope it will be fixed. Otherwise, it looks ridiculous losing the option to develop for Samsung S8 and any other phone with Android 8.
There were so many sonorous announcements about AR in 4.19 and BOOM Nothing at all!

I’m having this problem on my S9 with arcore apk installed, other apps off the market work fine

Basically to be short, all old ARCORE (below 1.0) is outdated in Android 8 and therefore neither of the applications going to support it. You should either re-compile them in the newest 4.18-github-google-arcore-1.0 or just re-make them in 4.19.1 following new rules, new blueprints and new API, whatever you have created in the past (below ARCore 1.0) is outdated and no longer supported by Android 8 which had automatically updated your arcore to 1.0 pretty recently. This is why we all got cut out from our applications.

Does people still having trouble using ARCore in Unreal 4.19 + Android 8? If so, please fill an issue here: Issues · google-ar/arcore-unreal-sdk · GitHub