Download

AR Camera overlay not working in 4.26 (ARKit)

When using the AR template project or any other AR projects, there is no camera overlay just black
CameraOverlay2.PNG

I have checked and Enable Automatic Camera Overlay is set to true in the session config

I’ve also tried disabling Mobile HDR and changing AA method

Am I missing something here? This has worked fine in all other versions but now seems to be broken in 4.26. I am testing on iPad 4th gen and iPhone SE

Did your app ask for permission to use the camera?
Try deleting the app and reinstall, it will then for sure ask for permission.

Is your ARConfig Session type set to “World”?

Hi, I’ve accepted permissions and tried a new version to accept again but it still wouldn’t work & yes it was set to world.

I think Epic is no longer supporting ARKit 2.0 which is what the older IOS devices use. ARKit 3.0 is only supported on the newer iPhones/iPad which have the A12 Bionic chip or better like the iPhone XR or XS.

Just FYI, this worked fine on a build done on a MacBook Pro, but has a black screen if we build from a brand new Mac Pro. Both running the latest OS X and both using 4.26 and the latest iOS.

If I figure out why, I’ll report back.

-Chilton

Thanks for the info! I have just bought an iPhone XR and it works fine on there. Seems it’s just the older devices that are not supported.

Okay so you need a device with ARKit 3 Support to run 4.26 AR apps, am I right?
Because there was a new post/question about this and I am a bit confused.

In my case the game is running fine on an iPhone 12, but not on an iPad Pro 2017 (you need at least iPad 2018 for ARKit 3)

Yes, I believe you need ARKit 3 support to run 4.26 apps but I have submitted a bug report as this does not appear to be documented anywhere, I’ll let you know when they back to me with an official answer.

1 Like

I actually found this today hidden deeply in the docs (https://docs.unrealengine.com/en-US/…s/index.html)::slight_smile: