Application Icon missing when building c++ project on another client pc


Based on this forum thread I opened a bug report:

to reproduce: Check in project in source control with the build folder excluded from Perforce. This is in line with what the documentation recommends.

Have another person check out the project. Visual Studio will report that the application.ico is missing and it cannot build the project. Is this a bug or did I make another error somewhere else?

p.s. I wanted to ask how you at Epic check in the project-based dll’s with perforce. The documentation says to use +w for dll’s which is what I set, too. But then perforce does not automatically checks out the newly build dll. Do you manually submit those changes or is there a setting to get this automated behaviour for ‘+w files’?



I am wondering if this is fixed with 4.7.1. - UE-10524 Icon reports failure to add if creating a project with source control enabled ? Did not know it was already logged and did not get feedback here. I guess this can be closed now?

bump any help?`Still not fixed for 4.7.3…

Hey -

Sorry for the delayed response. I was able to reproduce this issue by attempting to build a project with the Build/ folder missing and have submitted a bug report (UE-12556) for further investigation. For the time being it should be possible to build the project if the Build folder is included when checking in/out files to perforce as NisshokuZK mentioned in the forum thread. Additionally you can copy the Build folder from another local project after check out which should allow the build process to complete as well.


Hi and thanks for taking a look. Yes, with the build folder included in perforce, it works fine. My main concern is about if this is how it should be and if it is, the documentation should be changed. Anyway, thanks for submitting a new bug ticket! :slight_smile:

, thanks for looking at this but it is still a problem with 4.7.5. Is there any update on it? It has been a frustrating experience trying until I found this thread. Can we at least get an update to the perforce documentation saying you should add the build folder? I have been thinking my perforce setup is messed up because it says to not include the build folder

Hey -

The bug report mentioned earlier is still being investigated as to what is causing this issue. While including the build folder does solve this issue I can’t say for certain if doing so is a legitimate fix or simply a workaround for the problem.

4.7.6 still not fixed

Hey VTalyh-

I have updated the report to mention the fact that this is still being asked about however we don’t have a time frame for this at the moment. With the workaround of copying the Application.ico from another project or including the Build folder in source control check-in, it should still be possible to continue working in spite of this issue.

– 4.8 still not fixed.

Still a problem in 4.26.

Guy Paddock…What is still a problem. Lots has changed since 6 years and I can probably help you?

@: What’s still a problem is that UE still keeps the application icons in the Build/ folder alongside other output build artifacts, so if you create a project that ignores that folder, you won’t check-in the icons and then the next time you try to open the project UE won’t be able to recover from the missing icon.

Yes, just dont ignore the build folder and check it in, too :slight_smile: