APK not biulding and device not showing up

I understand that us is a wide range of questions, but when i launch my apk i run into a few problems
either it says:
ERROR: Couldn’t find 32-bit or 64-bit versions of the Android toolchain with NDKROOT: C:/Users/rphad/.android
or it says:
LogPlayLevel: Error: ERROR: The NDK API requested ‘android-19’ not installed in C:/Users/rphad/.android/ndk/22.0.7026061
is there a fix to this and how do i do it?
Also if it helps i have android 19 and 30 installed from android studio

Make sure your Android NDK files are in the folder C:/Users/rphad/.android . You might of installed them somewhere else. Another thing you can try is go to your Project Settings in Unreal Engine. Go to Platforms/ Android SDK. There you write in the location where your Android SDK and NDK files are.

that is all i have, but i still get the same errors

I think you need to fill in the location of the SDK and java as well. This is what mine looks like:

The settings must be set up like this also: https://developer.oculus.com/documen…t-guide-quest/ . Launching on Oculus requires your settings to be set up pretty specific and your going to get random errors regularly so be prepared for that.