Apex Clothing Error - No reference to RootNode

Hey there,

i am using MakeHuman and Blender to create the characters for my UE4 Project. With the help of some awesome tutorial vids i was able to import a rigged character with an idle animation to UE4. This was quite easy even for a non 3D Artist and UE4 noob like me :wink:

But for now i am struggling with the Apex Clothing tool from Nvidia.
The simulation looks just fine in the Apex tool. But in UE i am receiving some errors.

First one after i tried to import the apex file:

This file references bones which do not exist in the Skeletal Mesh:



I hit ok and went on. Second error comes up after i try to apply the apex file to the material:

There are no corresponding bones. At
least one bone should exist. This
Could be Improper APEX file.

Mapping failed bones : RootNode

Tested this with a cape created in blender on a MakeHuman mesh rigged with the basic mhx export rig.
Exported with the latest Fbx exporter from blender.

In Case my Bone Hierachy in Blender could help i attached a screenshot.
Hope anyone could point out what i am doing wrong :slight_smile:

Thanks in advance

When I had this problem I just renamed my root bone RootNode and then it worked.

Thanks for the reply and sorry to the admins for my double post. I guess my browser caused this.

When I had this problem I just renamed my root bone RootNode and then it worked.

Yes, thanks for this hint! It could solve the problem of the wrong named Root bone but in my case i messed up the whole rig.

I did not find a way to solve this manually but MakeHuman offers a UE4 Rig and T-Pose in their nightly build now.
In combination with MakeClothes for Blender, this is a very powerful and free character pipeline.

My first try went fine and everything worked but not perfectly. So this is my Result of a MakeHuman - UE4 exported Character model with weighted cloth on it (created with MakeCloth in Blender).

I used the retarget Manager to take use of the basic animation of the thirdpersoncharacter.
The model looks quite strange. f.ex. the thumbs, the feet and the neck looks just wrong.
The skin is coming through the cloth at some spots. I know this is a problem of MakeCloth / Blender but i just leave this here :slight_smile:

So is there anybody who imported a MakeHuman Character successfully into UE4 and set it up to a Player character, avoiding the strange look?
I would be so thankful for any information about this.

Oh man!
I worked about 8 hours and at the end of it, it doesn´t work!
Where are you able to rename the “rootnode”?
I wish, that ue would create the clothing tab inside, without exporting and importing…
Thanks for answer this question!

Hello again,
Maybe you know how to save a collisio generated body, and mix it with the knew mesh?
I worked about 8 hours for that.

I ran into this problem for many days and i actually found a fix for it…

For —> “This file references bones which do not exist in the Skeletal Mesh” <----

This Is because apparently your Apex cloth and imported mesh have altered bone/joint names. UE4 can sometimes associate your bone names differently when you import your mesh.

  1. Print screen your UE4 error message with the bones giving you errors.
  2. Load up your Skeleton tree in UE4
  3. load up the modeling software that was used to create the mesh ( maya, 3ds max, blender, ect)
  4. Locate the bone names in modeling software and rename them to match UE4’s names in the Skeleton tree.
  5. Re-Export your Apex Cloth from modeling software with the corrected bone names.

This should help fix your issues! Don’t forget to also “set” your mesh’s “maximum influences” to 4 in your graphics program before exporting your apex cloth! Google for it if you don’t know where to find it in your graphics program.

For me the RootNode issue in UE4 seems solved after clicking the “Generate Collision Volumes” button in Apex Clothing Tool.