Please select what you are reporting on:

Unreal Editor for Fortnite

What Type of Bug are you experiencing?



Hi there, my map is fully completed and ready to be published and have made sure that it is well under the maximum memory capacity allowed but when I launch a session and start a memory calculation it uploads to a private version alright but then loads into a new session disconnected from the Unreal Editor and then a minute later it loads into it again but still says it is disconnected from the editor. In the Unreal Editor the memory calculation is still going round and round but nothing appears to be happening. I have left it for well over an hour but havn’t had much luck with it. Only attempted to publish it yesterday so not too sure if it’s happening to anyone else and couldn’t find a fix.

Steps to Reproduce

Not too sure if it can be reproduced but try and see if memory calculation is working.

Expected Result

I was expecting something to show up in game once the memory calculation was finished but nothing showed up.

Observed Result

Launch session, wait until you are loaded into the map, press launch memory calculation, wait until it uploads a private version, then it should automatically start the memory calculation and should tell you the size of the world once completed.



Are you using HLODs & streaming ?

1 Like

Yeah I am.

Have you only got the props seen from a distance set to HLOD and all the little stuff not in HLOD ?

In the Build menu, do a Build Landscape first, then do Build HLODs but delete HLODs first before you build HLODs, hopefully it does something.

Ignore all the thousands of Yellow Warnings in Build Landscape results, filter them out with the drop down menu at the bottom and see if there are any red errors.

1 Like

I’m pretty sure most things have HLOD switched on even if the player will be stood right next to it, is there a quick way to remove all the HLOD? And then I can add them back.

Depending on the size and complexity, it may not be necessary as a fix for your issue.

try the Build Landscape and HLODs first, see if it works, unless you already did that just before launching memory calc.

As for HLOD, I am fixing up an old map with 7000+ actors, I just removed HLOD from all props and then did an editor fly around of each bit, selecting stuff that needed to be seen from a distance and re enabling HLOD on those.
Sounds a big job at 7000 actors, but not too bad. Only took a couple of hours. But worth it

Next map you’ll be able to set them when you place them.

1 Like

Okay, I’ll give it a try.

I’ve just had an issue with Validating assets for a launched session.

Headache, headache…yay, launched it.

From what I gather the Delete HLOD doesn’t work too well from build menu.

I just made a new HLOD layer in the Content Browser and Deleted the old HLOD layer, replacing its references to point to the new HLOD.
After using Build HLODs I am able to launch a session…phew

When it was doing its thing replacing references I noticed it had actors in it that had been deleted, so I gather the Delete HLOD is incomplete and leaves traces of stuff that messes with the validation.

Replacing and deleting the existing HLOD layer is probably the best way to go if any HLOD enabled actors get deleted or moved after a HLOD build.

1 Like

Yeah, I have attempted using the Delete HLOD from the build menu and didn’t seem to fix the issue unfortunately. I will try and delete the HLOD layer manually and see if that fixes anything.

I just did all what I said and tried a memory calculation, it gave me the infinite 0% memory check bug…

Restarted PC and tried again, it worked…
But I did, at the private upload code window, switch to Fortnite and move the player around in the air a little bit, hoping to “unstuck” something, then went back to UEFN to proceed with the memory check.

Hopefully its just a random glitch for you too

1 Like

I have attempted it but still hasn’t worked.


Does the Output Log give any useful info, red or yellow text ?

The output log doesn’t show anything that could be causing it, I have kind of found a way around it but it takes 1 in 80 attempts to work. I end the session and allow the memory thing to keep loading I then start many more sessions then eventually it sometimes work. This method I’ve been doing is very time consuming and not something I would like to keep doing to get a memory test done. So I’m still looking for a fix.

1 Like

Yeah thats hefty.

Another thing to try… just a longshot, maybe it could be a spawnpad glitch.

Select all your Spawnpads Copy them, Delete them and Paste them, I remember doing this to fix some between round spawnpad issue, that may have been due to them being a few updates old and a few people were using that as a fix at that time.

1 Like

I’ll give it a try.

It does not automatically start memory calc. It waits for you to start it after uploading is finished. Do a clean test: close both uefn and Fortnite, open and launch your project. Make sure it can start the game in game mode. Then click End game and wait. Then start memory calc. When it finishes uploading the private version there will be a small window where you need to click. Then calculation will succeed or fail.

Obviously, if start game fails in game mode you would need to address it first etc

1 Like