Anyone know why my normal maps look like this in UE4

This is a 4k normal map baked in Blender. It is on a mostly smooth and flat surface in this image and don’t know why this pattern of small squares shows up when it should be smooth here.

Could you show us the material node setup and the normal map itself?


Hello masterwigglestein,

Double click on your normal map in your details panel and then check to see if you have it set to normal map under

Compression Settings > Normal Map


I no longer have this issue. I’m not sure if my problem was something I did in Blender or UE4 but I seem to have resolved it somehow. Thank you help though. This can probably be closed.

Hello Masterwigglestein,

I haven’t heard from you yet and I was wondering if you were still experiencing this issue?

Also, if you add a normal map to a surface that has not been UV unwrapped in a modeling software you will experience issues there.

Let me know if you still need help.

Thank you,

Not a problem. Thank you for reporting this.