Anyone get oculus OVR LipSync plugin working in UE5?

I’m getting an issue when I build a lipsync file from an audio asset, UE crashes. It didn’t do this in 4.27, so my belief is that some part of OVR LipSync plugin needs to be updated. Some people were talking about it in the comments on THIS youtube video

someone there said they got it working by adding “AndroidPermission” to PublicDependencyModuleNames.AddRange in OVRLipSync.Build.cs

I did just that, but still getting crashes.

Anyone have any luck getting this plugin working in UE5?

1 Like

I have a temporary solution, you just need to find the picture with the red line and add SoundWave->LoadingBehavior = ESoundWaveLoadingBehavior::ForceInline;
Hope this works for you


Amazing! It was able to generate my lip sync files without a crash with your fix. Thanks so much! :smiley:

Glad to see it helped you.

1 Like

it worked like a charm. Thank you so much. As a beginner I am just curious to know how you were able to identify this issue at first place and correctly come to this conclusion. it seems like difficult one to solve.

1 Like

It is not difficult as what you think. You just need enough time to debug and find the problem.

1 Like

Hey, so I tried the above.
I’m not getting the crashing as much after adding the fix:
SoundWave->LoadingBehavior = ESoundWaveLoadingBehavior::ForceInline;

But I’m still not getting a proper asset. It will create an empty asset with no values. (And by no values, I mean, 0.0000s for the visemes]

Any ideas? I’m starting from 5.0.1 and never worked with this in earlier versions. The demo project opened fine for me in UE5 with a working OVR audio asset. But I couldn’t make any new ones.

Ok. this fixed it for me.

Issue was on how the audio was imported.
Edit the .WAV file and set Loading Behavior Override to “Force Inline”

After that, the LipSyncAsset is generated correctly.

It solved my problem, thank you so much! :smiley:

Sorry, you didn’t leave a message under my comment, so I didn’t see it. It can only work on versions above 5.0.2, because 5.0.2 updated the bug about ESoundWaveLoadingBehavior::ForceInline.
You can also set au.editor.ForceAudioNonStreaming=1 in the Editor

You’re welcome!

So, i have another issue with this plugin and don’t want to open a new topic but, did anyone managed to run a new project, import the plugin and make it work on npcs or player character ? Did i missed a file ?

Guys, Check this video about it.