Anyone else having trouble with exporting from Maya LT 2019?

Is anyone else having trouble with Maya LT 2019? I think I’ve tried everything and followed the documentation, but when I export a skeletal mesh with an animation, Unreal gives me an ‘empty animation’ warning and the animation doesn’t import.

Is anyone else having issues with Maya 2019 LT and UE 4.21.2 or is it just me?

Did you bake it, and select animation in the export options?

I tried that but it didn’t do anything until I chose “Import Bone Tracks” when importing in UE4. I can’t understand why baking didn’t seem to work. I’m new to Maya so I must be doing something fundamentally wrong somewhere, I must not be setting up the animation correctly.

I’m not sure what your workflow is with Maya, but I’ve recently started animating in Maya LT 2018. My process is I will rig and skin the mesh, then export the mesh and skeleton into UE4. I like to export individual animations by them selves, separately from the mesh. So when I export an animation, I select only the skeleton of the rig and choose “Export Selected”.

Then when bringing it into UE4, the prompt comes up and I just select the associated skeleton in the pop up box. I’ll attach a pic of my Maya export settings and UE4 import settings so you can try and match them up, hopefully it helps!

EDIT - Also another weird caveat I find is that if Im exporting an animation, the timeline has to be clamped to that certain animation that Im exporting. So if I’m exporting my animation which is from frames 100-160, I make sure the current timeline in the editor is set to those as well, otherwise it seems to import blank frames before or after. I’m quite new to maya as well, so that’s probably something goofy I’m doing wrong.

Thanks for the tips, I appreciate it!